0

My magento specifications are below:

  1. Magento 1.9.0.1
  2. PHP 5.3.3
  3. centos 6.6 (final)

I applied patch 6788 which was applied successfully without any errors. When I visit the new admin pages (block permissions, variable permissions) created by this patch, I get "There has been an error processing your request". In var/report the file mentions "Controller file was loaded but class does not exist".

I have tried flushing caches, deleting cache files, disabling compiler, Reloading the front page and even upgraded php to 5.4.4 but I keep getting this error.

Please suggest.

Thanks in advance!!

  • Did you tried logging out and in to PA? – versedi Nov 8 '15 at 8:41
  • @versedi. By PA do you mean admin panel of magento ? Yes I did logout and login to admin panel but no luck. – TheCoderGuy Nov 8 '15 at 8:47
  • Can you paste in the exact content of /app/code/core/Mage/Adminhtml/controllers/Permissions/BlockController.php? Magento will complain if it cannot find the exact class-name within that file. Examine the class declaration. It should match 'class Mage_Adminhtml_Permissions_BlockController extends Mage_Adminhtml_Controller_Action'. – Luke A. Leber Nov 8 '15 at 16:29
  • Hello @LukeA.Leber The file is not the issue as it is working on different installation with exact specifications. The file is created by the patch itself. class Mage_Adminhtml_Permissions_BlockController extends Mage_Adminhtml_Controller_Action – TheCoderGuy Nov 8 '15 at 17:44
  • 1
    If you are 100% sure the file is correct, then the only other thing I can think of is a third party full page caching setup that hasn't been properly purged. – Luke A. Leber Nov 8 '15 at 21:26
0

Turns out that SELinux was the culprit here. Apache was able to see the file but wasn't able to read the contents of the file. Apache was looking as the file as if it was blank.

I ran command getenforce which returned "Enforcing"

I change SELinux mode to "Permissive" by running setenforce 0

After above change, the file contents are visible to apache and everything is working fine now.

Hope this helps someone!!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.