My website on the checkout page is not sending everything as HTTPS, causing Firefox to give me the yellow padlock with the "Parts of this page are not secure" warning. Chrome also warns that "This page includes other resources which are not secure". You can replicate this by adding anything to the cart and going to the checkout page.

It appears only the body is loading HTTPS which seems to be causing the error. I considered making the entire site HTTPS as I read Google rewards sites that do so, however I have also read many comments about this being a bad idea, especially if you have cache enabled.

I noticed links beginning with / (like /store) switch to HTTPS correctly and links like {{media url="}} or {{base url="}} don't. However I doubt the ideal fix is to change all my links to "/". Also not sure it's even possible if I choose to do so.

To answer the question, yes I have the secure URL set in the (System->Settings->Web) section.
Any suggestions on how to stop browsers from seeing my page as insecure?

1 Answer 1


If this happening after applying the latest magento patch SUPEE-6788 try to disable cms block cache. I had the same problem which also persisted after me adding those cms blocks to magento whitelist.

  • Holy crap. It was really that easy? xD haha thanks a ton man! You are a lifesaver! Yay, shiny green lock icon!
    – SuperMar1o
    Commented Nov 7, 2015 at 22:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.