1

I'm using Magmi 0.7.21 and Magento CE 1.9.2.1 with Magmi being run through the datapump API.

When importing my products I'm making sure to have the "+" added in front of the base image path, but this doesn't result in my base images having the "exclude" checkbox unticked in admin for some reason.

I have tried setting "Image import mode" to "overwrite" in Magmi config.

Everything else to do with the Image attributes processor seems to work as advertised.

Does anyone have any tips or could anyone confirm that this works with the API? The documentation is pretty clear about how to achieve this and I've followed it to the letter as far as I know, but no joy.

[update]

I can work around this using the following after import. May be useful to anyone else with the same issue.

public function updateGalleryExclude($arg_skus)
{
    $query = 'UPDATE `catalog_product_entity_media_gallery_value` AS a
        INNER JOIN `catalog_product_entity_media_gallery` AS b ON a.value_id = b.value_id
        RIGHT JOIN `catalog_product_entity` AS c ON c.entity_id = b.entity_id
        SET a.disabled = 0
        WHERE c.sku IN ("' . implode('", "', $arg_skus) . '")
        AND a.disabled = 1';

    $result = $this->db->query($query);

    return $result;
}
  • Welcome to Magento SE. I have a feeling this may get marked as off topic, even though Magmi is an essential piece of kit. I recommend posting an issue on the github, Sebastian is pretty quick on support / problems. github.com/dweeves/magmi-git/issues – AreDubya Nov 4 '15 at 18:48
  • @AreDubya good idea, thank you - I'll do that now. – gpcola Nov 4 '15 at 18:53
  • I searched Magmi's git issues list and found someone else opened an identical issue back in August last year but there has been no answer from the dev so far github.com/dweeves/magmi-git/issues/93 :( – gpcola Nov 4 '15 at 19:01
  • Well, there goes my comment about 'pretty quick' out the window! I would go ahead and post a new issue there, while he's quick he's also busy, the original could have gotten lost in the shuffle. Hopefully this will stay open - enough of us use Magmi for it to have a tag, so that's something. While I use Magmi a lot unfortunately I can't advise on this particular problem. Good luck! – AreDubya Nov 4 '15 at 19:05
  • I opened a new issue github.com/dweeves/magmi-git/issues/360 so we'll see how that goes, but hopefully this will stay open too, as I've seen dweeves post on SE in the past. Thanks again ;) – gpcola Nov 4 '15 at 20:08
1

I believe I have figured out what was wrong here. I was specifying all of image, small_image and thumb but they were all set to the same image. I was only adding the '+' to image and not to small_image and thumb and consequently the exclude flag wasn't being updated the way I expected it to be. Adding + to all 3 seems to work as intended.

  • perfect answered , i was also trying the same as you mentioned to add+ in front of image but we need to add + on all image fields. Thanks – Rohit Goel Aug 8 '16 at 12:23
  • Glad to have helped ;) – gpcola Aug 8 '16 at 15:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.