1

I ran many time reindex process and system always returning the status "required index". I truncate the table without success.

  • System sometimes returns "There was a problem with reindexing process." – Eduardo Luz Oct 3 '13 at 14:04
  • is there anything in the log files when you see this error message? – David Manners Oct 4 '13 at 7:52
  • Thanks for the help. I cleaned my var/reports and rebuild with success. Now it's ok. – Eduardo Luz Oct 7 '13 at 20:08
1

Check which events set the indexes to invalid

Magento docs show the events for every index (see Events that Trigger Reindexing):

Further you can add some debug code in Mage_Index_Model_Resource_Process::updateStatus()

if ($status === Mage_Index_Model_Process::STATUS_REQUIRE_REINDEX) {
    Mage::log(sprintf('Indexer %s was invalidated.', $process->getIndexer()->getName()), null, 'invalid_index.log', true);
    foreach (debug_backtrace() as $db) {
        Mage::log(sprintf('%s::%s', $db['class'], $db['function']), null, 'invalid_index.log', true);
    }
}

This should show you a stack trace about what is setting the indexes to invalid. In my case it were API requests of 'catalogProductUpdate'

You can also check the exception.log if you'll find any locks of the 'index_process' table. This tables holds the data you see in System > Index Management

Creds for the debug code go here

| improve this answer | |
0

In case of error when rebuilding index. Go into your magento var/report path and clean old errors and try again.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.