1

Upgraded magento 1.8 to 1.9.2.2 and having this error:

Package community/Lib_Varien 1.9.2.2 depends on PHP extensions: Array

Anyone could know how solve this ? What Exactly need to be done? Also I'm installing the upgrade on root httpdoc/ is it the correct root?

3
  • Is that the entire error message? Commented Nov 7, 2015 at 15:21
  • I am also getting same error after Magento Connect wizard but i am upgrading from 1.9.2.1 to 1.9.2.2. Error is "CONNECT ERROR: Package community/Lib_Varien 1.9.2.2 depends on PHP extensions: Array". I tried upgarding another website but it went well but this site got stock.
    – Anil Prz
    Commented Nov 10, 2015 at 3:13
  • Enable PHP mcrypt extension. It should fix it
    – Bonik
    Commented Nov 22, 2015 at 22:02

1 Answer 1

2

I've just checked var/package/Lib_Varien-1.9.2.2.xml and it contains the following dependencies:

<dependencies>
    <required>
        <php>
            <min>5.2.0</min>
            <max>6.0.0</max>
        </php>
        <package>
            <name>Lib_ZF</name>
            <channel>community</channel>
            <min>1.12.10.2</min>
            <max>1.12.10.2</max>
        </package>
        <extension>
            <name>PDO</name>
            <min></min>
            <max></max>
        </extension>
        <extension>
            <name>SPL</name>
            <min></min>
            <max></max>
        </extension>
        <extension>
            <name>curl</name>
            <min></min>
            <max></max>
        </extension>
        <extension>
            <name>SimpleXML</name>
            <min></min>
            <max></max>
        </extension>
        <extension>
            <name>dom</name>
            <min></min>
            <max></max>
        </extension>
        <extension>
            <name>gd</name>
            <min></min>
            <max></max>
        </extension>
        <extension>
            <name>iconv</name>
            <min></min>
            <max></max>
        </extension>
        <extension>
            <name>pdo_mysql</name>
            <min></min>
            <max></max>
        </extension>
        <extension>
            <name>mcrypt</name>
            <min></min>
            <max></max>
        </extension>
        <extension>
            <name>pcre</name>
            <min></min>
            <max></max>
        </extension>
        <extension>
            <name>Reflection</name>
            <min></min>
            <max></max>
        </extension>
        <extension>
            <name>session</name>
            <min></min>
            <max></max>
        </extension>
    </required>
</dependencies>

So you should check your server and Magento install to see if all of this is in place. If it isn't you have to solve this before Lib_Varien-1.9.2.2.xml can be installed.

More details on a similar issue can be found here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.