1

I tried to upgrade Magento from Magento Connect, but when I started the process the report window said:

Checking dependencies of packages

CONNECT ERROR: Package community/Cm_RedisSession 1.9.2.2 conflicts with: community/Mage_All_Latest 1.9.2.1)

In my root there isn't the folder "pkginfo". What should I do?

1

It is not the simple way to update by magento connect. I most of the time get problems with apache as it is most of the time too long to run. The best is to copy the new sources on your installation and open the website (best to call index.php from cli).

The website and the database will be automatically upgraded.

The reasons that can push you not to do so :

  • your installation contains overwrite of core sources in the core itself (really bad practice). The update throught connect would not be better indeed...
  • you changed basic magento files in the default theme (bad practice as well). The update will destroy your templates...
  • you modified basic magento files in the lib, shell or skin folders (still bad practice)

If not, then go on... Think to put website in maintenance before running and flush cache and recompile after it.

0

I had the same problem - I had left the compiler enabled - but that wasn't the only problem.

I deleted the directory named pkginfo/MageAllLatest.txt (sounds like it should just be a file, but it isn't) and the upgrade worked successfully via Magento Connect Manager.

0

I have tried removing the pkginfo directory like suggested and Mage Connect Manager started the upgraded 1.9.2.3 > 1.9.3.0.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.