1

SUPEE-6788 - Patching file notice, but file not patched

We read:

patching file app/design/frontend/base/default/template/persistent/customer/form/register.phtml

and then when we check the files the patch is not applied

There is an htaccess error / patch cannot be applied - but we run nginx

How can I force the patch to apply?

  • If there's a single error line, the patch will not apply. On running, the patch tests all items and then gives you a report listing everything that will apply and everything that will fail. – Fiasco Labs Oct 31 '15 at 16:30
4

Replace the .htaccess and .htaccess.sample with an original stock version, then run the patch. I had the same problem and it was because my .htaccess lines weren't matching up, so no files were patched.

  • Thanks - I manually applied some fixes, but these I also had to remove again to get the full patch file working. However now I see my blocks are not in order and whitelisted so we needed to run whitelist (github.com/rhoerr/supee-6788-toolbox) ... trouble is that when I try and access the whitelist tables in settings I receive an error "SQLSTATE[42S02]: Base table or view not found: 1146 Table 'mage.permission_variable' doesn't exist SQLSTATE[42S02]: Base table or view not found: 1146 Table 'mage.permission_block' doesn't exist" – snh_nl Oct 31 '15 at 15:18
0

please download the latest magento 1.9.2.2 and replace with current version.

Please take backup of current version before uploading new files.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.