0

I'm currently applying patch SUPEE-6788 to a store that is running Magento CE 1.9.1.0 (it says so at the bottom of the admin panel).

When it comes to selecting the version for the patch, I'm a bit confused:

  • Do I have to select "SUPEE-6788 for CE 1.9.1.0", as that is the latest update of Magento that I've installed?

  • Do I have to select "SUPEE-6788 for CE 1.9.2.1", as I have already installed all previous patches, making my Magento installation identical to a 1.9.2.1 installation?

2 Answers 2

1

You need SUPEE-6788 for CE 1.9.1.0, since that is the version that you are running. The patch will address security issues only, there are other changes between 1.9.1.0 and 1.9.2.x.

2
  • Ah, great, so "SUPEE-6788 for CE 1.9.1.0" assumes that I have installed CE 1.9.1.0 and ALL patches leading up to SUPEE-6788? That's where I'm a bit confused.
    – Louis B.
    Oct 30, 2015 at 14:33
  • yes, you'll want to install all security patches for 1.9.1.0 in the order that they were released
    – STW
    Oct 30, 2015 at 14:34
1

Now that we have never understood with Magento, you have to login to their website/repository, find new release or patch, then you have to find out what version you are actually running right now, then download this patch, and when you will try to apply it you will get ton of errors, some of them are pretty stupid and obvious. There must be a shell/php script provided from magento that will do this all for you, all you have to enter is your MAG id, and downloads token:

thats why we have tried to create some automatic procedure: https://gist.github.com/magenx/18669dfa81444bcf4ddf

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.