3

I am using Magento 1.9.2.1 and have installed SMTP pro module to send email.

When I run smtp self test from admin, it successfully sends email to provided email id.

But on customer signup, order placed and click on send email button from admin, there is no mail sent to customer/guest.

When I load "mydomain.com/cron.php" or set cron setting in cpanel, no mail is sent to customer.

Please tell me the email settings for Magento 1.9.2.1 and what is the problem here?

1

When I load "mydomain.com/cron.php"

If you've got a properly set up server, this wouldn't happen anyway, the route for cron.php should be blocked from web traffic.

If you have patched recently with SUPEE-6788 then a change to the default .htaccess file means that this URL is now inaccessible.

Your cron should only ever be executed using cron.sh by crontab/CLI - and needs to be run at 1 minute intervals in order to avoid mail delivery issues.

See https://magento.stackexchange.com/a/73100 for a more thorough explanation.

0

You can change below setting and order emails send directly without adding in queue..

Go to system->configuration->Aschroder Extensions->Smtp pro-> Queue Configuration->Queue Usage set it to never

and your order email goes directly

-1

I have the same problem in my couple of sites in recent past.

As in the latest magento version, magento has introduce new feature of processing the order confirmation email in a queue, so we must have to configure cron.php to call every 5 minutes in order to make this scheduled task work properly.

This cron.php file indirectly calls the cron.sh file which you will find in the webroot directory of your magento site.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.