0

When going to the Sales Orders page (Sales > Orders) I receive an 500 Internal Server Error. I found one post which appears similar in that it discusses this problem, but which doesn't seem to really address my problem fully:

https://stackoverflow.com/questions/12466312/magento-site-crashes-when-going-to-the-sales-orders-page

Checking the PHP logs, I can reproduce the following error when going to the Sales Orders page:

 PHP Fatal error:  Call to a member function setSaveParametersInSession() on a non-object in /data/html/app/code/core/Mage/Adminhtml/Block/Widget/Grid/Container.php on line 66

I've found a number of references while researching this error; however they refer to the problem resulting from a custom grid and this error I believe is coming from a stock install. Here is one such article:

 http://magento.stackexchange.com/questions/43343/magento-fatal-error-setsaveparametersinsession-on-a-non-object

Can anyone give me some pointers on how to move forward? This is Magento ver. 1.14.2.1, running on a 64 bit CentOS box.

1

Looking at that line (66) in /data/html/app/code/core/Mage/Adminhtml/Block/Widget/Grid/Container.php, we find the following code:

    $this->setChild( 'grid',
        $this->getLayout()->createBlock( $this->_blockGroup.'/' . $this->_controller . '_grid',
        $this->_controller . '.grid')->setSaveParametersInSession(true) );

It is basically setting up your grids for the page.

This error would typically mean that a grid has been improperly added to the page. I would start by going through the module declaration xml files for custom modules (start with those that might have an admin grid). Disable it in xml, clear cache, check the page to see if it works.

Once you narrow it down to a particular module, then we can narrow down what it's doing wrong.

  • are the custom modules kept under app/etc/modules? – Gedalya Oct 30 '15 at 0:41
  • Yes, the declaration for all modules is in app/etc/modules. Anything that doesn't start with Enterprise_ or Mage_, open one by one, and change <active>true</active> to <active>false</active>, save, clear cache, test. If it has no affect, change it back to true until you find the culprit. – TJ Gamble at Jamersan Oct 30 '15 at 1:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.