I am using Magento version in a WAMP Server.

  1. I disabled a custom module through the Admin section (Configuration > Advanced > Disable modules output). Even after I did re-indexing and cleared cache, I am able to access a page that is created with the module.

  2. After setting <active> from true to false in the etc/modules/Mymodule.xml file, I got the 404 page error.

For disabling a module in magento, should I follow both the above steps?

Or will it be done automatically when I follow the first step?

  • in which page,you got the error 404.? – Amit Bera Oct 28 '15 at 6:57
  • I created a custom page through that module which should be disabled. Only after following the second step, I got the 404 error when I tried to access that page. – Kiran Tej Oct 28 '15 at 7:00
  • if you disable the module from mymodule.xml it will definitely show you a 404 error. – Mujahidh Oct 28 '15 at 7:03
  • @mujas: That's exactly what I want. – Kiran Tej Oct 28 '15 at 7:03

From (Configuration > Advanced > Disable modules output) this action only disables module output as it says. If your module uses, let’s say some Observer functionality to hook into some part of the system and does some overriding then those actions won’t be disabled.

To fully disable module, you need to go to module config file, like



If you just want to disable your module output you can disable it from

Admin -> Configuration -> Advanced -> Disable modules output

But if still show your module page in frontend after disabling module from admin, try to change Current Configuration Scope: to website and per store and see if it is disable for both also.


if the both option not work then rename the module file




this will work without error.

  • No, Magento parses all xml files in app/etc/modules, the file name does not matter. – Fabian Schmengler Dec 31 '15 at 12:39
  • @fschmengler it worked for in many cases. so i share this solution. – Qaisar Satti Dec 31 '15 at 12:42
  • 1
    OK, it might be that hidden files (starting with a dot) are ignored. I was not aware of that – Fabian Schmengler Dec 31 '15 at 12:44

Not the answer you're looking for? Browse other questions tagged or ask your own question.