3

I am running in into this weird error on our site http://amanvida.eu. The problem is hard to recreate, and I haven't been able to pin point a cause. It does happen more often when you are logged in and left the page open for a long time.

At some point the website will not load, it just keeps requesting and after a while an Maximum execution time error pops up which refers to a random line somewhere in Magento.

Fatal error: Maximum execution time of 99 seconds exceeded in /home/users/amanvftp/amanvida.eu/app/code/core/Zend/Db/Select.php on line 1018

or

Fatal error: Maximum execution time of 99 seconds exceeded in /home/users/amanvftp/amanvida.eu/lib/Varien/Object.php on line 109

Fatal error: Call to a member function quote() on a non-object in /home/users/amanvftp/amanvida.eu/lib/Zend/Db/Adapter/Pdo/Abstract.php on line 296

or

Fatal error: Maximum execution time of 99 seconds exceeded in /home/users/amanvftp/amanvida.eu/lib/Varien/Object.php on line 0

The error is different with every refresh.

The only solution to getting this error solved is to clear the cookies in your browser cache. Problem is that regular users won't know this and will have to wait a long time before they can reach the site again.

Has anyone every encountered this error before? I have no idea where to start looking to solve this.

Nothing shows up in the exception.log or system.log

PS This error does not show up in the admin section.

  • If you have php.ini file, then please increase the value of max_execution_time – Triyugi Narayan Mani Oct 27 '15 at 13:24
  • If same setup working fine in localhost then you should be upgrade the server configuration. Magento doesn't work fine on shared server. Can you please check your current server configuration and mentioned it. – Praful Rajput Oct 27 '15 at 13:31
  • But then how come clearing the cookies suddenly resolves the problem. I have the problem right now for example, But in an incognito window it is working just fine and fast. – Gilles Lesire Oct 27 '15 at 13:35
  • What are the specifications of your server and what have you changed in Magento, which modules are installed etc – Sander Mangel Oct 27 '15 at 13:49
1

Turning off persistent shopping cart seems to resolve the situation. But I wouldn't call it a "solution". There is a deeper issue at hand here.

  • Did you find a better solution? I don't want to have to resolve to this solution. In my case, it only happens to some users, not all, and it's everytime they log in with social networks. – Vic Feb 27 '16 at 16:00
  • I never found a different solution, and I know this "solution" is a bummer. You'll have to weight for yourself which is worst for your conversion, loss of some customers, or loss of persistent shopping cart. If you find a solution elsewhere, please let me know. – Gilles Lesire Feb 29 '16 at 8:37
  • We kept testing and testing and realized it was just happening to some specific accounts. No matter the device they used. My account never got the problem. I realized also that the customers that couldn't log in also could not be viewed in the customer section of the Magento Admin. We found the problem to be in our custom shipping module. The affected accounts had something I'm they're cart (not sure if a product or an address yet) that caused an error calculating shipping costs. We were able to fix it this way, so now I guess our problem was specific to us. – Vic Feb 29 '16 at 12:17
  • Hello @GillesLesire, I have the same issue since six months, I haven't found any solution or root cause at this time. Do you have any new information ? Have you found another solution ? Thanks for your update. – olcha Aug 25 '16 at 13:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.