-1

I'm trying to install magento 2 on WAMP Windows 10. I have downloaded. When i run it gives error

Autoload error "Vendor autoload is not found. Please run 'composer install' under application root directory."

So i have googled & through stackoveflow Q/A. I have installed composer @ C:\wamp\bin\php\php5.5.12 where my php.exe is located.

Curl & OpenSSl is enabled in WAMP.

Now when i go through magento-2 directory. It still saying

enter image description here

closed as off-topic by 7ochem, Raphael at Digital Pianism, Fabian Schmengler, Amit Bera, Marius Aug 31 '16 at 14:47

  • This question does not appear to be about the Magento e-Commerce platform within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 4
    I'm voting to close this question as off-topic because this question is about getting Composer installed on Windows 10 in the first place. – 7ochem Aug 31 '16 at 13:32
3

Composer Windows Installer adds composer.bat location (C:\ProgramData\ComposerSetup\bin) to the system PATH environment variable automatically, but the Windows Command Prompt program need to be restarted to reread the new PATH value.

  • Ohh. Need to close command prompt & reopen again & it works :) . Small things matters. Thanks Dmirty. – Mike Oct 23 '15 at 2:10
  • Composer is installed. Still installation issue is not solved. " composer repositories with package information Installing dependencies (including require-dev) from lock file - Installing phpunit/php-text-template (1.2.1) Downloading: Connecting... Could not fetch api.github.com/repos/sebastianbergmann/php-text-template/…, please create a GitHub OAuth token to go over the API rate limit Head to github.com/settings/tokens/… to retrieve a token. – Mike Oct 23 '15 at 2:20
  • The new problem is irrelevant to your initial problem "'composer' is not recognized as an internal or external command". – Mage2.PRO Oct 23 '15 at 2:24
  • Ok Dmitry. Got solution for that as well using this url tutorials.scrisoft.com/…. Now able to install Magento 2 :) – Mike Oct 23 '15 at 2:32
0

When I was installing Magento 2 I faced the same issue. As you may know, you can install composer easily. Then problem is how to proceed with next steps. If my assumption is correct you can try the following to solve this issue.

  1. remove unwanted variable from PATH(Environment variable). Because, in my case I tried installing composer many times and I had been added the path multiple times. So finally, I figured out and removed unused variables. Anyway double check this PATH variable.
  2. Make sure PHP also added in that variables.

I had defined the path variable as E:\xamp\php\;C:\Users\USER_NAME\AppData\Local\ComposerSetup\bin

And close windows explorer and prompt window. Even if it is throwing the same error, restart your machine and try.

Not the answer you're looking for? Browse other questions tagged or ask your own question.