1

I've been dealing with a problem all morning where my website is working just fine but I can't access the admin panel. It's not that I can't log in, I can't even load the admin login screen. It was working perfectly yesterday.

The resulting page when accessing the admin is a completely blank page with no HTML, just a basic response header.

To make matters worse, I'm not being able to make the Magento log work, not even through

Mage::log("something to log")

when it's placed in Mage_Core_Controller_Varien_Front->dispatch.

PHP(apache) not throwing any errors either. Log files do work for apache.

I'm really out of ideas for this one. Any thoughts would be greatly appreciated.

3
  • Make sure you don't have a directory in you magento's root with the same name as your backend's directory e.g. admin. Have you trying acessing mysite.com/index.php/admin ? Commented Oct 21, 2015 at 22:06
  • http status code is 200 or 500?
    – MagenX
    Commented Oct 22, 2015 at 7:37
  • Thanks for the responses. There is no admin folder in root dir, and I get 404 when I try accessing mysite.com/admin as expected. Code when trying to access admin is 200
    – Felipe C.
    Commented Oct 22, 2015 at 13:26

1 Answer 1

2

Found the issue. Not sure how it happened but my adminhtml directories from app/design/ and skin/ had been mysteriously deleted. I brought the dirs from another Magento install and everything is working fine now.

Thanks for the help!

1
  • 1
    Great you found solution, but how was your directories deleted? I doubt it has been compromised unless you did yourself. I would suggest to check all thoroughly. Commented May 16, 2016 at 0:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.