6

I made some inline styling changes on a Transactional Emails template. My changes are visible when I preview the Transactional emails template. but the problem is when I send a test email to a gmail I still get an old version of the Transactional email template. My new changes don't show up. I cleared the cache and I did Reindexing. but my My new Transactional email template doesn't show up.

Is there a step that i'm missing? or Is this problem related to Magento or the Server?

  • did you make these changes to the System > Transactional Emails or to the email files in app/locale/[language]_[country]/template/email/...? – Sander Mangel Sep 30 '13 at 13:13
  • I made the changes on System > Transactional Emails – Mthe beseti Sep 30 '13 at 13:15
  • thanks for clarifying, you can find my response in the answers :) – Sander Mangel Sep 30 '13 at 13:19
  • Did any of the answers help you out with your question? – Sander Mangel Oct 1 '13 at 10:43
6

Make sure the emails you've edited are choosen under System > Configuration > Sales > Sales Emails > [type of email] > [type of email] Email Template / [type of email] for guests

Other emails like the one for welcoming a new user are spread out over the System > Configuration, for example under Customer Configuration > Create New Account Options. You'll have to locate the email templates you have updated.

By default all these dropdowns are on [...] (Default Template From Locale), select your modifications name from the dropdown

4

Have you assigned these templates in the system configuration for the store you're testing?

After creating a transaction email template you need to tell the store to use this for the relevant email.

So for example the New customer email is assigned in System Configuration -> Customers -> Customer Configuration -> Default Welcome Email

  • 4 minutes too slow, +1 – SR_Magento Jan 5 '15 at 12:59
0

Inline css not works in gmail. Gmail only supports <style> in the <head>. Gmail does support embedded styles (<style>). However, embedded styles are only supported in the head of your HTML document.

so if you added css in style in the head section it will not work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.