0

I've bumped into an odd problem on my local running version of Magento 1.9.2.1. I installed the Fishpig Splash Pages plugin which was working fine, but I uninstalled it (as I was testing different plugins to see which worked best).

I then decided this extension was the best one that was going to suit my requirements so I reinstalled it. After this install, One or more of the Indexes are not up to date - meaning I had to run the Attribute Splash reindex, but when running this I received the error: Cannot initialize the indexer process. I then tried manually running the indexer via \shell\indexer.php --reindex - and this produced some PHP errors that indicate the tables don't even exist.

I then created a brand new install of Magento running 1.9.2.1 - the plugin installed fine and correctly created the splash pages database tables. What could be causing my other copy not to do so?

1

You did not include the steps taken during uninstallation, so this is only a guess: You forgot to remove the respective entry in the core_resource table.

mysql> SELECT * FROM `core_resource` WHERE `code` = 'attributeSplash_setup';

With this entry still present, the (re-)installation process skips the (re-)creation of the extension's database tables.

  • You hero! Thanks! I assumed the uninstallation of a plugin would have carried out such steps but I completely overlooked this! – Liam McArthur Oct 21 '15 at 9:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.