15

I am getting the error Fatal error: Class 'IntlDateFormatter' not found in Magento2 after installation.

3 Answers 3

21

Just need to clear comment before this line in php.ini file:

;extension=php_intl.dll

to

extension=php_intl.dll
2
  • In my /etc/opt/remi/php70/php.ini' not has ;extension=php_intl.dll. I install php7 in /opt/remi/php70`. Any suggestion?
    – xanka
    Feb 15, 2017 at 4:43
  • recompiled again with an additional parameter (--enable-intl)
    – Mehdi
    Mar 19, 2018 at 20:23
5

sudo apt-get install php7.0-intl did the trick for me on Ubuntu 18.04.

(That's with this PPA repo containing a backport of PHP sudo add-apt-repository ppa:ondrej/php.)

1

I had same issue but in my case intl was installed and loaded checking php -m. brew install icu4c resolved issue on my Mac. I'm using php 5.6.30 by the way.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.