5

When I'm trying to edit a product(the product already has an image) and add another image, the image is uploaded correctly in the /media/catalog/.. directory. The image is displayed correctly in the Admin-area, the mousehover and everything is working fine.

After save the product, the image is disappeared in the Admin-area and that is not displaying on front end either.

There are no errors in the php or Magento log.

Thank you for your help.

6
  • is the image file still in media/catalog after saving the product?
    – paj
    Oct 13, 2015 at 15:04
  • Yes. It's still under media/catalog/product/e/x/example.jpg. Oct 13, 2015 at 15:11
  • Do you see an error in your browser console log when you edit the product image, or view the image in the frontend. Something is blocking the image from loading, so it is either a server permissions / config problem or a client browser error. Inspect the image element in your browser and copy the url, then try opening the url to the image in a new browser window.
    – paj
    Oct 13, 2015 at 15:13
  • no errors or warnings in the browser log. I can open the (url)/media/catalog/../example.jpg image inside the Browser. Oct 13, 2015 at 15:25
  • Have you tried another browser in case there is some problem with your browser. Have you cleared your browser cache, cookies, history etc ?
    – paj
    Oct 13, 2015 at 15:36

2 Answers 2

2

Taking into consideration the fact that image upload is working fine for products we can eliminate an issue with flash uploader and some common issues like GD etc. The list of things to check can be the following:

verify the existence of media/catalog/category directory with correct permissions 777 in case it is media/tmp check also permissions (777) and additionally flush it check that you have not ran out of the disc space

2

To anyone else running into this: I had the same problem, fiddled for hours with directory permissions, disabled all modules, found this thread, until I discovered the Magento installation was including some WP code in the index.php:

$url = "http://" . $_SERVER["SERVER_NAME"] . $_SERVER["REQUEST_URI"];
if(strpos($url, "admin") === false)
{
    define("WP_USE_THEMES", false);
    require_once($_SERVER["DOCUMENT_ROOT"] . "/wp-load.php");
}

Then I remembered we changed the admin path to something different, so WP code WAS loaded when using the admin. After changing the

if(strpos($url, "admin") === false)

to the real admin url, the problem was solved!

1
  • This Question is asked for magento not a wordpress. Sep 25, 2018 at 6:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.