1

I having an issue. For some reason the attributes filter are not showed. I enable some logs and I saw this:

If I set the is anchor to YES this is the executed query:

SELECT `e`.*, `cat_index`.`position` AS `cat_index_position`, `price_index`.`price`, `price_index`.`tax_class_id`, `price_index`.`final_price`, IF(price_index.tier_price IS NOT NULL, LEAST(price_index.min_price, price_index.tier_price), price_index.min_price) AS `minimal_price`, `price_index`.`min_price`, `price_index`.`max_price`, `price_index`.`tier_price`, `at_stock_status`.`stock_status` FROM `catalog_product_entity` AS `e`
 INNER JOIN `catalog_category_product_index` AS `cat_index` ON cat_index.product_id=e.entity_id AND cat_index.store_id=25 AND cat_index.visibility IN(2, 4) AND cat_index.category_id='86' AND cat_index.is_parent=1
 INNER JOIN `catalog_product_index_price` AS `price_index` ON price_index.entity_id = e.entity_id AND price_index.website_id = '1' AND price_index.customer_group_id = 0
 INNER JOIN `cataloginventory_stock_status` AS `at_stock_status` ON (at_stock_status.`product_id`=e.entity_id) AND (at_stock_status.stock_status = '1') AND (at_stock_status.website_id = '1') ORDER BY `price_index`.`min_price` asc, `price_index`.`min_price` asc LIMIT 8

if i set to NO this is the executed query:

SELECT `e`.*, `cat_index`.`position` AS `cat_index_position`, `price_index`.`price`, `price_index`.`tax_class_id`, `price_index`.`final_price`, IF(price_index.tier_price IS NOT NULL, LEAST(price_index.min_price, price_index.tier_price), price_index.min_price) AS `minimal_price`, `price_index`.`min_price`, `price_index`.`max_price`, `price_index`.`tier_price`, `at_stock_status`.`stock_status` FROM `catalog_product_entity` AS `e`
 INNER JOIN `catalog_category_product_index` AS `cat_index` ON cat_index.product_id=e.entity_id AND cat_index.store_id=25 AND cat_index.visibility IN(2, 4) AND cat_index.category_id='474' AND cat_index.is_parent=1
 INNER JOIN `catalog_product_index_price` AS `price_index` ON price_index.entity_id = e.entity_id AND price_index.website_id = '1' AND price_index.customer_group_id = 0
 INNER JOIN `cataloginventory_stock_status` AS `at_stock_status` ON (at_stock_status.`product_id`=e.entity_id) AND (at_stock_status.stock_status = '1') AND (at_stock_status.website_id = '1') ORDER BY `price_index`.`min_price` asc, `price_index`.`min_price` asc, `price_index`.`min_price` asc LIMIT 8

This is the weird part. for NO the cat_index.category_id='86'

for YES the cat_index.category_id='474'

My category ID is 474, NOT 86 . I have no any category with the value 86. All of the settings from admin panel is well done. I have products with attributes a,b,c and I have product which belongs to category 474. So it is not an administration settings. Can someone help me with this ? thx

1

It was xml configuration issue. The id 86 came from the xml settings:

<reference name="before_body_end">
            <block type="mana_filters/layer" name="mana_layer" as="mana_layer" before="-">
                <action method="setCategoryId"><category_id>86</category_id></action>
            </block>
        </reference>

I had to remove it and add this is xml code for showing the navigation layer:

<reference name="left">
            <block type="catalog/layer_view" name="catalog.leftnav1" after="currency" template="catalog/layer/view.phtml"/>
        </reference>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.