1

I create a system tab but when I click Configuration then It selected my tab which order 200 (after catalog) and when i click My custom tab option it's give me a 404 page

My system.xml is

<config>
<tabs>
    <firstnewtab>
        <label>My custom tab</label>
        <sort_order>200</sort_order>
    </firstnewtab>
</tabs> 
<sections>
    <mytab_options>
        <label>My custom tab options</label>
        <tab>firstnewtab</tab>
        <show_in_default>1</show_in_default>
        <show_in_website>1</show_in_website>
        <show_in_store>1</show_in_store>
        <groups>
            <my_options1>
                <label>Options</label>
                <frontend_type>text</frontend_type>
                <show_in_default>1</show_in_default>
                <show_in_website>1</show_in_website>
                <show_in_store>1</show_in_store>
                <sort_order>30</sort_order>    
                <fields>
                    <percent translate="label">
                        <label>Label 1</label>
                        <frontend_type>text</frontend_type>
                        <sort_order>1</sort_order>
                        <show_in_default>1</show_in_default>
                        <show_in_website>1</show_in_website>
                        <show_in_store>1</show_in_store>
                    </percent>
                </fields>
            </my_options1>
            <my_options2>
                <label>Options2</label>
                <frontend_type>text</frontend_type>
                <show_in_default>1</show_in_default>
                <show_in_website>1</show_in_website>
                <show_in_store>1</show_in_store>
                <sort_order>40</sort_order>    
                <fields>
                    <percent2 translate="label">
                        <label>Label 2</label>
                        <frontend_type>text</frontend_type>
                        <sort_order>1</sort_order>
                        <show_in_default>1</show_in_default>
                        <show_in_website>1</show_in_website>
                        <show_in_store>1</show_in_store>
                    </percent2>
                </fields>
            </my_options2>
        </groups>
    </mytab_options>
</sections></config>     

UPDATE config.xml

<config>
<modules>
    <Alanstormdotcom_Helloworld>
        <version>1.0.0</version>
    </Alanstormdotcom_Helloworld>
</modules>
<global>
    <helpers>
        <helloworld>
            <class>Alanstormdotcom_Helloworld_Helper</class>
        </helloworld>
    </helpers>
</global></config>
3

ACL permission is missing in your module. so add that to your module. ACL permissions are used to give proper permission for your modules configuration section.

File : app\code\{codePool}\{Namespace}\{Module}\etc\adminhtml.xml

<config>
    <acl>
        <resources>
            <admin>
                <children>
                    <system>
                        <children>
                            <config>
                                <children>
                                    <mytab_options translate="title" module="cms">
                                        <title>Mytab Options</title>
                                    </mytab_options>
                                </children>
                            </config>
                        </children>
                    </system>
                </children>
            </admin>
        </resources>
    </acl>
</config>

After put this modifications, you need to clear the cache first. Then you need to sign out from backend and login again to see your system config section.

  • Thanks Now 404 out. When I click that link that's work properly. But why it's selected first? I set <sort_order>200</sort_order> but It selected when I click configuration. – Abdus Salam Oct 13 '15 at 4:05
  • @AbdusSalam I didnt get your question. put some higher number there. may be 1000. I think the answer resolved your problem which you have described in the question. So feel free to accept the answer. – Rajeev K Tomy Oct 13 '15 at 4:32
  • 1
    About the preselection, please refer to magento.stackexchange.com/questions/73243/… – Fabian Schmengler Oct 14 '15 at 14:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.