1

whenever i try to upload an image on product page it gives this error:

Upload HTTP Error

Given all permissions to all the required folders and cleared cache.

Any solution?

7

If you are using PHP 7 then go to

lib/Varien/File/Uploader.php

Find the following code

$params['object']->$params['method']($this->_file['tmp_name']);

And replace it with

$params['object']->{$params['method']}($this->_file['tmp_name']);
0

You can check apache error log.as well as ask your hosting provider if PHP is running in FastCGI mode and if there is MaxRequestLen limitation.

  • already checked this isn't working for me – Donika Oct 12 '15 at 10:41
  • .htaccess and .htpasswd issue i think – Bishal Neupane Oct 12 '15 at 10:45
  • means what kind of issue? – Donika Oct 12 '15 at 10:46
  • have you protected directory with password – Bishal Neupane Oct 12 '15 at 10:48
  • which directory? – Donika Oct 12 '15 at 10:50
0

You can refer the below link in which given the steps to follow to solve this error:- https://stackoverflow.com/questions/18994648/magento-upload-http-error Possible to try all this steps.

0

You may have exceeded the file size or dimensions that are set. I've had this error before when trying to upload an image that's several MB. Try a test image less than 500k. If it works, then try adjusting your PHP settings to something like the below:

; Maximum allowed size for uploaded files.
upload_max_filesize = 10M

; Must be greater than or equal to upload_max_filesize
post_max_size = 10M
-1

I think it's a permission problem or you have to increase

upload_max_filesize 
post_max_filesize

in the php.ini file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.