2

I am having trouble with my Magento module name in parallel Plesk. My module's name is like ComPany/MYMODULE and it works fine in localhost.

But I uploaded it to a live server in Parallel Plesk, I m getting error such as Source model "mymodule/entity_attribute_source_yesnodefault" not found for attribute "mymodule_update_images"

It seems case-sensitivity plays the role here. So I changed the MYMODULE folder to my module and changed ComPany/mymodule/etc/config.xml appropriately. But no use! Still, the local works fine and the Live server gives the error!

How can I overcome this error? If you have any Idea, share...

2

Case sensitivity may indeed be your issue here. If the server is case sensitive and your local machine is not, you can expect this behaviour.

You should start all folder and file names in your module with capital letters. The model in question should have the following path:

app/code/local/ComPany/Mymodule/Model/Entity/Attribute/Source/Yesnodefault.php

Your config.xml file and app/etc/modules file should define your module name as ComPany_Mymodule, and the model configuration should map the lowercase mymodule to the classes in ComPany_Mymodule_Model:

<models>
    <mymodule>
        <class>ComPany_Mymodule_Model</class>
    </mymodule>
</models>
  • 1
    I would also add the suggestion of setting up a case-sensitive file partition for developing locally. – davidalger Feb 21 '13 at 2:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.