0

This question already has an answer here:

i am using magento 1.9.2.1 , but i am unable to login to admin using google chrome browser where as login works fine in firefox browser ,

Please guide me how to fix ,

1: in chrome when i enter wrong password i get error but for correct login details now error just admin login page reloads

2: please tell what to do to fix it

3: i have cleared cache many time and issue is on server only

in chrom after login url is like below

abc.ocm/index.php/admin/index/index/key/we1**************************/

marked as duplicate by Rajeev K Tomy, liyakat, 7ochem, Mufaddal, Keyur Shah Oct 9 '15 at 10:25

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Please clear your cookies, browsercache, etc and try again – Sander Mangel Oct 9 '15 at 7:28
  • have you installed on Ip address or on localhost? – huzefam Oct 9 '15 at 7:28
  • Hi go to system -> configuration -> in left general menu -> web -> Session and cookie management->set yes http only – Magento 2 Oct 9 '15 at 7:30
  • i had alreay set it – user1799722 Oct 9 '15 at 7:34
  • also my website is on subdmoain can this be issue – user1799722 Oct 9 '15 at 7:38
2

This is a well known old issue which exist in Magento. However there is no single, elegant solution for this.

Refer this Thread and see Alanstorm's answer. There is nothing more I can say about this issue. Here I am quoting the possible reasons for this issue

Possible causes include

  • Local computer time vs. server time mismatch, causing instant cookie invalidation. Make sure your server time is correct.

  • Incorrect permissions on var/session, preventing session files from being saved

  • Incorrect configuration of database/redis/other session storage, preventing saving of session values

  • A module is instantiating sessions to early, preventing the correct session names from being set

  • You're a developer using multiple URLs and have multiple cookie domains

  • Another developer has somehow modified app\code\core\Mage\Core\Model\Session\Abstract\Varien.php, creating a hard to track down bug

  • The cookie domain in System -> Configuration -> Web -> Session Cookie Management doesn't match the actual site domain.

  • You're using the localhost as your server domain, and using a version of webkit that has trouble/bugs setting cookies for localhost in some situations.

The short term fix is to just delete your cookie for the domain. That's often enough to solve the problem. If it persists, figure out which of the above reasons is the reason for your error, and take steps to address it (fix permissions, etc.)

  • have you on holiday ..doing answering on lot of question :) – Amit Bera Oct 9 '15 at 8:20
  • @AmitBera no I am in good mood to answer now :) Normally I would be here, but only do moderating most of the time :) – Rajeev K Tomy Oct 9 '15 at 8:24
  • @AmitBera ha ha same for you :) – Minesh Patel Oct 9 '15 at 8:27
  • I think both are on holiday @MineshPatel :-) – Keyur Shah Oct 9 '15 at 10:26
0

If you want to go with @Rushabh Shah's answer follow these steps

Copy file

app/code/core/Mage/Core/Model/session/abstract/varien.php

to

app/code/local/Mage/Core/Model/session/abstract/varien.php

Go to line number 95 and comment out cookieParams array and and define $cookieParams as array like below

    // session cookie params
    /*$cookieParams = array(
        'lifetime' => $cookie->getLifetime(),
        'path'     => $cookie->getPath(),
        'domain'   => $cookie->getConfigDomain(),
        'secure'   => $cookie->isSecure(),
        'httponly' => $cookie->getHttponly()
    );*/
    $cookieParams = array();

This will tempary fix issue with login in google chrome but we still need to find out "why ?"

0

If you want to open admin using chrome ,

1.Open the admin panel first using another browser(like Mozilla).

2.Then go to admin panel check configuration, system->configuration->web->session & cookie management in that the HTTP control set from Yes to No.

3.Then open admin in chrome browser easily.

Hope this will help you.

Not the answer you're looking for? Browse other questions tagged or ask your own question.