2

How to set the product page layout to 2 columns-left instead of 1 column.

I've had a look around in catalog.xml but no joy, I've been looking for catalog_product_view

3 Answers 3

6

Make your changes in the local.xml of your template folder to make sure they're not overwritten. If it doesn't exist you can go ahead and create it.

Then add:

[...]
<catalog_product_view>
   <reference name="root">
      <action method="setTemplate"><template>page/1column.phtml</template></action>
   </reference>
</catalog_product_view>
[...]

And that should do the trick.


For details, refer to "How to use local.xml / theme.xml" in What is the correct way/approach to modify a Magento template?

4
  • Nicely done - but this is all product pages. If it's one-at-a-time use my solution.
    – philwinkle
    Commented Sep 26, 2013 at 17:46
  • 1
    So now we wait and see if he want's to do a one time fix or all pages ;) Commented Sep 26, 2013 at 17:49
  • Thanks for the reply, I can do it via the backend but you can only do that per product ? i have over 3000. I will try the Local.xml file now but thatsnot working, I didnt have a Local.xml so i created one but no success
    – Michael
    Commented Sep 26, 2013 at 17:54
  • Where did you create the local.xml? Commented Sep 27, 2013 at 6:59
2

Easy-peasy - there's a backend setting for that in the product edit screen > Design:

enter image description here

You can also use the "update attributes" mass action in the product grid to update many products at once:

enter image description here

0
1

change layout of product view page to 2 columns-left instead of 1 column

Go to file path by FTP :- app/design/frontend/default/default/layout/catalog.xml

Catalog Product View (Any) page/1column.phtml can change 1column to 2columns-left.phtml.

We can also use local.xml need to be add

page/2columns-left.phtml

1
  • Could you please tell me where this can be done in Magento 2.. i mean the file path or location..There is no such default/layout/catalog.xml in Magento 2 if im right
    – Sushivam
    Commented Aug 11, 2016 at 12:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.