3

I download a live site and installed it in localhost. I am using windows and xampp. I can see home page but if I click on a category page then Magento showing "Object not found!" .

Can anyone say where is the problem ??

11
  • Have you changed base url in database ?
    – Arunendra
    Oct 8, 2015 at 10:47
  • Check if you downloaded .htaccess file or not along with everything else.
    – Prateek
    Oct 8, 2015 at 10:49
  • login admin sys->config->left side menu(general)->Use Web Server Rewrites->(set No)
    – Magento 2
    Oct 8, 2015 at 10:59
  • @Arunendra -- I did that. Prateek -- I think I did not download .htaccess file. I am using Windows. LearningMagento -- I could not find your location.
    – abu abu
    Oct 8, 2015 at 11:24
  • Have you enable developer mode from index.php?
    – Arunendra
    Oct 8, 2015 at 11:31

3 Answers 3

2

use this

System-> Configuration -> left menu you can find web-> under that Use Web Server Rewrites-> set no
1

To make products appear on the site, the first step is to make sure such a product is available through a category. But there are more things to think about. The product status can be set to "Enabled" or "Disabled". The product can also be made visible through the "Catalog", or only through "Search", or both - but it can also be made invisible, which means that though the product is enabled it's not appearing anywhere on the site.

Because a single product could appear not only in the catalog (meaning: product categories) but also through search, you also need to determine if a product is part of a specific store anyway. This is done through the tab "Websites".

In a glance To give you a quick overview, a products appearance in the shop depends on the following settings:

General > Status General > Visibility Categories Websites

1

Solution to get the categories on front end :

You have asked for I can see home page but if I click on a category page then Magento showing "Object not found!" Right...?

Okay, for this, by based on my knowledge, You can achieve this in two ways. They are.

Solution 1:

First You need to login to your admin panel of magento.

After that follow:

  1. Goto catalog-->manage categories
  2. You need to select that particular categories and change the url of that category.
  3. And select Save option for that category.
  4. Just reindex the data and refresh your homepage and select categories.

Other wise

Solution2:

You can use this

System-> Configuration -> left menu you can find web-> under that Use Web Server Rewrites-> set no</p>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.