0

My magento indexing page showing processing only.

I tried http://www.magikcommerce.com/blog/how-to-resolve-magento-reindexing-errors-in-your-magento-store/#

not working, could anyone please suggest a solution for this

enter image description here

actual error after clicking on reindex data

Fatal error: Class 'Mage_Catalog_Model_Resource_Product_Indexer_Price_Configurable' not found in /home/damarokiatest/public_html/app/code/core/Mage/Catalog/Model/Resource/Eav/Mysql4/Product/Indexer/Price/Configurable.php on line 37

  • Check running processes on your server, indexing might actually be running. – Prateek Oct 6 '15 at 13:55
0

Just try this script in your root folder let us assume filename:reindex.php

Place it in your root folder

<?php
//Following 3 lines will load the magento admin environment.
require_once 'app/Mage.php';
$app = Mage::app('admin');
umask(0);

// to reindex the processes we require their ids
// for default magento there are 9 processes to reindex, numbered 1 to 9. 
$ids = array(1,2,3,4,5,6,7,8,9);

// Sometimes there are processes from our custom modules that also require reindexing
// We need to add those ids to our existing array of ids
// To know the id of process, just hover on each process in your
// admin panel-> System-> Index Management
// You will get a url : admin/process/some_id/......
// this id corresponds to the process

$ids = array(1,2,3,4,5,6,7,8,9,390,391,478);
foreach($ids as $id)
{
//load each process through its id
try
{
$process = Mage::getModel('index/process')->load($id);
$process->reindexAll();
echo "Indexing for Process ID # ".$id." Done<br />";
}
catch(Exception $e)
{
echo $e->getMessage();
}
}
?>

After that run www.domain.com/reindex.php

it will take 5 - 10 min

  • "Indexing for Process ID # 1 Done" i gots this after runing www.domain.com/reindex.php – Shiva Reddy Oct 7 '15 at 4:37
  • it will show all id's then logout and login your admin panel – Magento 2 Oct 7 '15 at 4:48
  • actually when i tried to re-index i am getting this error Fatal error: Class 'Mage_Catalog_Model_Resource_Product_Indexer_Price_Configurable' not found in /home/damarokiatest/public_html/app/code/core/Mage/Catalog/Model/Resource/Eav/Mysql4/Product/Indexer/Price/Configurable.php on line 37 – Shiva Reddy Oct 7 '15 at 4:53
  • this is front end or back end error – Magento 2 Oct 7 '15 at 4:54
  • backend error when i click on product prices reindex data – Shiva Reddy Oct 7 '15 at 4:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.