0

hang image

25 product import fine but when I create CSV above 30 product with images site hang I have already change php.ini with this option

memory_limit = 2048M 
max_file_uploads = 1000
upload_max_filesize = 512M
max_execution_time = 18000
mysql.connect_timeout = 400
post_max_size = 256M
max_input_nesting_level = 256

++++++++++++++++++++++++++++++++++++++++++++++++++++
htaccess code 
++++++++++++++++++++++++++++++++++++++++++++++++++++
############################################
## uncomment these lines for CGI mode
## make sure to specify the correct cgi php binary file name
## it might be /cgi-bin/php-cgi
#    Action php5-cgi /cgi-bin/php5-cgi
#    AddHandler php5-cgi .php
############################################
## GoDaddy specific options
#   Options -MultiViews
## you might also need to add this line to php.ini
##     cgi.fix_pathinfo = 1
## if it still doesn't work, rename php.ini to php5.ini
############################################
## this line is specific for 1and1 hosting
    #AddType x-mapp-php5 .php
    #AddHandler x-mapp-php5 .php
############################################
## default index file
    DirectoryIndex index.php

############################################
## adjust memory limit
#    php_value memory_limit 64M
#    php_value memory_limit 256M
#    php_value max_execution_time 18000
############################################
## disable magic quotes for php request vars
    php_flag magic_quotes_gpc off
############################################
## disable automatic session start
## before autoload was initialized
    php_flag session.auto_start off
############################################
## enable resulting html compression
    #php_flag zlib.output_compression on
###########################################
# disable user agent verification to not break multiple image upload
    php_flag suhosin.session.cryptua off
###########################################
# turn off compatibility with PHP4 when dealing with objects
    php_flag zend.ze1_compatibility_mode Off


###########################################
# disable POST processing to not break multiple image upload
    SecFilterEngine Off
    SecFilterScanPOST Off


############################################
## enable apache served files compression
## http://developer.yahoo.com/performance/rules.html#gzip
    # Insert filter on all content
    ###SetOutputFilter DEFLATE
    # Insert filter on selected content types only
    #AddOutputFilterByType DEFLATE text/html text/plain text/xml text/css text/javascript
    # Netscape 4.x has some problems...
    #BrowserMatch ^Mozilla/4 gzip-only-text/html
    # Netscape 4.06-4.08 have some more problems
    #BrowserMatch ^Mozilla/4\.0[678] no-gzip
    # MSIE masquerades as Netscape, but it is fine
    #BrowserMatch \bMSIE !no-gzip !gzip-only-text/html
    # Don't compress images
    #SetEnvIfNoCase Request_URI \.(?:gif|jpe?g|png)$ no-gzip dont-vary
    # Make sure proxies don't deliver the wrong content
    #Header append Vary User-Agent env=!dont-vary


############################################
## make HTTPS env vars available for CGI mode
    SSLOptions StdEnvVars


############################################
## enable rewrites
    Options +FollowSymLinks
    RewriteEngine on
############################################
## you can put here your magento root folder
## path relative to web root
    #RewriteBase /magento/
############################################
## uncomment next line to enable light API calls processing
#    RewriteRule ^api/([a-z][0-9a-z_]+)/?$ api.php?type=$1 [QSA,L]
############################################
## rewrite API2 calls to api.php (by now it is REST only)
    RewriteRule ^api/rest api.php?type=rest [QSA,L]
############################################
## workaround for HTTP authorization
## in CGI environment
    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
############################################
## TRACE and TRACK HTTP methods disabled to prevent XSS attacks
    RewriteCond %{REQUEST_METHOD} ^TRAC[EK]
    RewriteRule .* - [L,R=405]
############################################
## redirect for mobile user agents
    #RewriteCond %{REQUEST_URI} !^/mobiledirectoryhere/.*$
    #RewriteCond %{HTTP_USER_AGENT} "android|blackberry|ipad|iphone|ipod|iemobile|opera mobile|palmos|webos|googlebot-mobile" [NC]
    #RewriteRule ^(.*)$ /mobiledirectoryhere/ [L,R=302]
############################################
## always send 404 on missing files in these folders
    RewriteCond %{REQUEST_URI} !^/(media|skin|js)/
############################################
## never rewrite for existing files, directories and links
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !-l
############################################
## rewrite everything else to index.php
    RewriteRule .* index.php [L]

############################################
## Prevent character encoding issues from server overrides
## If you still have problems, use the second line instead
    AddDefaultCharset Off
    #AddDefaultCharset UTF-8

############################################
## Add default Expires header
## http://developer.yahoo.com/performance/rules.html#expires
    ExpiresDefault "access plus 1 year"

############################################
## By default allow all access
    Order allow,deny
    Allow from all
###########################################
## Deny access to release notes to prevent disclosure of the installed Magento version
    
        order allow,deny
        deny from all
    
############################################
## If running in cluster environment, uncomment this
## http://developer.yahoo.com/performance/rules.html#etags
    #FileETag none


4
  • Are you sure this settings get used, due to the fact, that magento's .htaccess is changing the settings? – Fabian Blechschmidt Oct 5 '15 at 18:08
  • you can check my htaccess code – Usman Fayyaz Oct 5 '15 at 18:34
  • Is php using those settings if you output it though phpinfo() are those values set? – rob3000 Oct 6 '15 at 0:49
  • Enabling error reporting or developer mode and checking the logs would help here. Probably a memory limit issue – Robbie Averill Oct 9 '15 at 2:37
1

issue has been resolved. Use these setting on php.ini

extension=pdo.so
extension=pdo_sqlite.so
extension=sqlite.so
extension=pdo_mysql.so
memory_limit = 8192M
max_file_uploads = 5000
upload_max_filesize = 512M
max_execution_time = 72000
mysql.connect_timeout = 2400
post_max_size = 512M
1

After import process, magento will reindex all the indexer. due to this reason it is taking time or hanged up.

you can try following steps:

Step 1: Set indexer mode to manually from System > Index Management > Mass Actions

Step 2: Import your products

Step 3: Re-index Individually by clicking on "Reindex Data" action

Step 4: Set indexer mode to "Update on Save"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.