1

Authorize.net on magento .1.9.2 is not working with Test mode set to NO. It is giving Gate way error(Gateway error: This transaction has been declined. Response code 103). When Test mode is Yes . It is accepting transactions. I don't know what is wrong with it. I tried new trasaction key, cleared cache , reindexed.

Can anyone please help me.

  • It's look like your transaction key is invalid for live mode. you will need to recheck it. – Akhilesh Patel Oct 1 '15 at 18:15
  • Same transaction key working on other platform and it is accepting all transactions. – Afrin Shaik Oct 1 '15 at 18:17
  • And what about API Login ID and Merchant's Email? Is it also same as other platform? – Akhilesh Patel Oct 1 '15 at 18:26
  • Also check your payment method settings by changing Current Configuration Scope to website and store. – Akhilesh Patel Oct 1 '15 at 18:29
  • yes, It has same login id and merchant's email – Afrin Shaik Oct 1 '15 at 18:44
0

If you are testing in the sandbox, you should not set your gateway to test mode nor should you include testmode=true in your request. If you do, the gateway will only check if the credentials are correct and return OK. It will not attempt to process a transaction.

You can read more about error 103 here: http://developer.authorize.net/api/reference/responseCodes.html?code=103

  • If I set Test mode to false, It is throwing Gateway error with response code 103. – Afrin Shaik Oct 1 '15 at 17:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.