3

I have a Magento CE 1.7.0.2 installation, and I want to install these Patches:

SUPEE-6482: SUPEE-6482 for CE 1.7.x - 1.8.0.0 (0.01 MB)
SUPEE-6285: SUPEE-6285 for CE 1.7.0.0 - 1.7.0.2 (0.05 MB)
SUPEE-6237: USPS API Patch - CE 1.6.x-1.9.x (0.01 MB)
SUPEE-5994: SUPEE-5994 for CE 1.6.0.0 - 1.9.1.1 (0.04 MB)
SUPEE-5344: Magento-CE-v1.7.x (0.01 MB)
SUPEE-1533: Magento-CE-v1.7.x (0.01 MB)
SUPEE-4291/4334: Magento-CE-v1.7.x-1.8.x (0.01 MB)
SUPEE-1868: Magento-CE-v1.7.x (0.01 MB)
SUPEE-2725: Magento-CE-v1.7.0.0-1.8.1.0 (0.01 MB)
PHP 5.4: Magento-CE-v1.7.0.0-1.7.0.2 (0.01 MB)
APPSEC-212: Magento-CE-v1.6.0.0-1.7.0.2 (0.01 MB)

This is the Error i get:

$ ./PATCH_SUPEE-1868_EE_1.12.x_v1-2015-02-10-08-29-37.sh 
Checking if patch can be applied/reverted successfully...
ERROR: Patch can't be applied/reverted successfully.

checking file app/code/core/Mage/Paypal/Model/Express/Checkout.php
checking file app/code/core/Mage/Usa/Helper/Data.php
checking file app/code/core/Mage/Usa/Model/Shipping/Carrier/Usps.php
Hunk #5 succeeded at 406 (offset 3 lines).
Hunk #6 FAILED at 444.
Hunk #7 succeeded at 528 (offset 6 lines).
Hunk #8 succeeded at 554 (offset 6 lines).
Hunk #9 succeeded at 668 (offset 6 lines).
Hunk #10 succeeded at 680 (offset 6 lines).
Hunk #11 succeeded at 735 (offset 6 lines).
Hunk #12 succeeded at 755 (offset 6 lines).
Hunk #13 succeeded at 780 (offset 6 lines).
Hunk #14 succeeded at 803 (offset 6 lines).
Hunk #15 succeeded at 839 (offset 6 lines).
Hunk #16 succeeded at 855 (offset 6 lines).
Hunk #17 succeeded at 876 (offset 6 lines).
Hunk #18 succeeded at 889 (offset 6 lines).
Hunk #19 succeeded at 933 (offset 6 lines).
Hunk #20 succeeded at 968 (offset 6 lines).
Hunk #21 succeeded at 995 (offset 6 lines).
Hunk #22 succeeded at 1023 (offset 6 lines).
Hunk #23 succeeded at 1356 (offset 6 lines).
Hunk #24 succeeded at 1702 (offset 6 lines).
Hunk #25 succeeded at 1712 (offset 6 lines).
Hunk #26 succeeded at 1745 (offset 6 lines).
Hunk #27 succeeded at 1883 (offset 6 lines).
1 out of 27 hunks FAILED
checking file app/code/core/Mage/Usa/Model/Shipping/Carrier/Usps/Source/Method.php
checking file app/code/core/Mage/Usa/etc/config.xml
checking file app/code/core/Mage/Usa/sql/usa_setup/upgrade-1.6.0.1.1.1-1.6.0.1.1.2.php

Whats the correct order to install the patches?

0

You are trying to install an EE patch onto Magento CE, I think that patch does not apply there.

The only thing you need to worry about for order is to apply everything else before 6788, then you can do 7405 and 7616 (as of right now since this post is quite old)

Try a site like https://www.magereport.com/ to see what patches you really needed. The hunk failures may require you to replace any core overrides/previously modified files that are different from what a given patch expects.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.