My website is lightning fast (loads under 1 second) using different AJAX and Caching extensions, but all grinds to a complete stop when checking out. Load times can jump up to around 10 seconds, sometimes even more. Even refreshing /checkout/onepage/ can take forever.

I know this issue probably depends on numerous things, but let me begin by asking how I would be able to narrow down the causes. Is there some debugging mode available that can tell me what exactly is being loaded while waiting?


Profile, Profile, Profile.

Obviously you have serious performance problems, which you hide behind :

different AJAX and Caching extensions

Fix this.


The main problem with the speed in the checkout is the cache module. Magento use a cache module witch use the Zend_Cache library and create a huge numbers of files that makes the site terrible slow. You can easy replace it with this:
or even better, magento is prepared to work with Redis. With this feature the cache goes to RAM instead the File System. It's a little more tricky but, like I said, Magento it's prepared to use it so it.
Good luck!


here is possible reasons for slow magento checkout:

  • magento has to query too many shipping gateway URLs to collect shipping rates. disable UPSP, UPS, Fedes, DHL shipping methods if you don't use them.
  • you are using magento that means new order email is sent during checkout - check how fast is that. if mail server is down customers will wait forever after they click on submit order button.
  • magento gift message extension adds its 2 cents to checkout page load time. disable it if you don't need it.

you don't need fancy profilers mentioned above - enable default magento profiler or use simple Aoe Profiler and check the trace - it could be some third party extension observers slowing you down.

See these 7 fixes for slow magento site as well.


The Solution that worked for me when all other methods failed to get my Magento fast is simple 1) Activate a genuine https certificate and redirect all traffics through it 2) Goto .htaccess and php.ini file and increase php memory limit to at least 2G.

After trying countless methods, this was what finally got my website loading to speed up in Magento's default mode even without Full page cache turned on

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.