2

Please note I have tried the reference post that is a possible duplicate. The error only happens in System config when I try to save a new Product Placeholder

I am getting the following error when trying to save a product place holder. I am able to save product images without an issue.

2015/10/01 12:48:58 [crit] 10749#0: *2 open() "/var/lib/nginx/tmp/client_body/0000000001" failed (13: Permission denied), client: 76.xxx.xxx.221, server: www.damin.us, request: "POST /index.php/someadmin/system_config/save/section/catalog/key/fb1b1054099c511522a4e2eb696cd55a/ HTTP/1.1", host: "www.domain.us", referrer: "http://www.domain.us/index.php/someadmin/system_config/edit/section/catalog/key/03a8b3dd274e9c375fa768d3f920fba0/"
2015/10/01 12:50:39 [error] 10749#0: *29 access forbidden by rule, client: 54.xxx.xxx.235, server: www.domain.us, request: "POST /app/etc/local.xml HTTP/1.1", host: "www.domain.us"

I have tried this without success Getting “access forbidden by rule” error at magento in nginx server /app/etc/local.xml

UPDATES:

I have set my permissions on the entire site to 644 and 755 with my var, media and app/etc to set to o+w. Problem still is happening.

  • @QaisarSatti I referenced that post in my post saying I Tried that and it did not work. Please read my entire post. – brentwpeterson Oct 1 '15 at 13:19
  • Do you use a custom admin theme? – Fabian Schmengler Oct 1 '15 at 13:43
  • No, standard theme – brentwpeterson Oct 1 '15 at 13:58
2

The problem is actually with the first part of the error in the log

*2 open() "/var/lib/nginx/tmp/client_body

The user assigned to that account was user:nginx, I switched the site to run on nginx:nginx and then re-chowned the folder /var/lib/nginx/tmp to nginx:nginx and it works.

The problem was that the main user did not have right to create the tmp file in that folder.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.