1

I have two attributes sets "Default" and "bibliografi". I have another attribute for images as "att_eby_images" . In the website, images does show for products under "bibliografi" but it is not showing under "Default" attribute set. The att_eby_image is there in the "images" tab in the admin.

Dont know where I am going wrong, please help

0
  1. In back end go to System -> Cache Management. Click all check boxes. Choose ‘Refresh’ option from ‘All Cache’ drop down. Click ‘Save Cache Settings’. Once the page reloads select ‘Disable’ from drop down and again press ‘Save Cache Settings’.

  2. On the same page you will find a button ‘Clear’ beside ‘Images Cache’. Click it.

  3. Go to Catalog -> Manage Products. Click the specific product. Go to ‘Images’ tab. Beside the image there will be 3 radio buttons (Base Image, Small Image, Thumbnail). See if the required radio is selected or not. Also check if Exclude is checked or not. If checked uncheck it and save product.

  4. Upload another image. Assign all radio to that image. Save the product. Then reassign the required radio options to the actual image and save again. 5.Check for all browsers/ check your memory limit for php_value memory_limit 256M

And yes also clear your browser cache. I hope by now the image is showing in front end.

The problem might be because of folder permission. You can try giving 777 permission to media folder and all its sub directories and see if it does any help.

2
  • Hi, it is showing for another attribute set (bibliografi) but it is not showing for "Default" attribute set. That is the issue, if it is not showing for "all" then I get your point, but it shows for one attribute set. BTW images is a attribute att_eby_images and stored in different folder altogether – Shakthi TG Sep 30 '15 at 10:39
  • Hi, I have a attribute with type "TEXT" as att_eby_image which stores the URL of the image. For eg. the attribute att_eby_image has the url "hardyart.co.uk/AllPrintImages/large/FAR1014.jpg" as one of the value for a product I added this attribute to "DEFAULT" attribute set and "Bibliografi" attribute set. Now what happens is the website shows all the images that is under attribute set "Bibliografi" but the website is not showing images that is under attribute set "Default". I changed the rights of Media image to 777, the images are present in the directories – Shakthi TG Oct 2 '15 at 5:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.