6

I have installed the patch for my magento site and checked it in Magento Patch test.

Previously it showed site is safe. But when I check now, it returns

UNKNOWN: That URL doesn't seem to be accessible.

But both the frontend and backend URL is working fine.

I checked the patch test in Magereport

It returns, the installed patches.

I need to know why the Magento patch test returned error.

3

The code at http://magento.com/security-patch is outdated, as it only tests for patch 5344. It is hosted by Magento, so we cannot tell you why it fails. Perhaps your firewall is blocking the Magento probe IP?

However, Magereport.com is continuously developed/maintained and covers all recent security patches. If that gives you a green light, I would say your patch installation has been successful.

(I'm from byte.nl)

2
  • Thanks @Willem. But last time it showed site is safe. It shows error now only. I didn't added any new patch
    – vinothavn
    Sep 29 '15 at 12:55
  • 1
    So check your access.logs while you issue a Magento patch check.
    – Willem
    Sep 29 '15 at 13:15
2

It's because that test was hosted on Magento site via byte.nl. They no longer provides that check on a separate URL, it was a temporary service until detailed reports were published about that particular vulnerability.

2
  • Thanks for your @prateek. When I check other sites, it returns either "site is safe" or "patch it immediately". But shows error for the particular site only. Any idea?
    – vinothavn
    Sep 29 '15 at 12:20
  • 2
    In that case, only someone from Magento itself can explain why this is happening. As Willem mentioned, Magereport.com is better place for check patches. Also, just checked Magento patch test with a non-magento site, and it returned "Safe".
    – Prateek
    Sep 29 '15 at 12:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.