0

i'm having some problems with my website. when i try to access a different page like a product page, i get a 404 error, but when i add index.php in the link it works. i've tried to update the database table core_config_data for the web/unsecure/base_url and web/secure/base_url so that they include the index.php but then for some reason my theme isn't applied and the whole layout of the website is messed up as no styling is applied. Is there anyway i could include the index.php so that it is included in all url links as without it my pages show 404 errors.

Any help is much appreciated

5
  • 1
    In admin panel goto system->configuration->left side(general)->web-> Use Web Server Rewrites-> set no
    – Magento 2
    Sep 25, 2015 at 11:01
  • i don't have that option
    – AN11
    Sep 25, 2015 at 11:54
  • which version you are using
    – Magento 2
    Sep 25, 2015 at 11:55
  • i am using magento 1.9
    – AN11
    Sep 25, 2015 at 11:56
  • it's ok glad to help you
    – Magento 2
    Sep 25, 2015 at 14:28

1 Answer 1

0

In admin panel goto

system->configuration->left side(general)->web-> Use Web Server Rewrites-> set No 

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.