0

Hi My site name is xpressbuyer.com.

I have tried almost all solution, but nothing seems to be working. Below things i have done.

  1. Add code in .htaccess
  2. Set Use Web Server Rewrites to YES in Search Engine Optimisation tab
  3. Added

    <directory "="" var="" www="" html"="">
    AllowOverride All
    </directory>
    

in .htaccess file.

Could you please direct me to find a solution for this?

  • In admin panel goto system->configuration->left side(general)->web-> Use Web Server Rewrites-> set yes – Magento 2 Sep 25 '15 at 5:13
  • clear your cache and session – Magento 2 Sep 25 '15 at 5:14
  • I did it already but still the issue remains same. – Ashesh Sep 25 '15 at 8:31
  • Is your server configured properly to handle mod_rewrite ? – Raphael at Digital Pianism Sep 25 '15 at 8:36
  • I have enable mod_rewrite by command "a2enmod rewrite" & it gives message that "Module rewrite is already enabled". Let me know if there is any other setting – Ashesh Sep 25 '15 at 8:39
0

Please check your webserver config file (e.g. apache2.conf) if AllowOverride All is set (default is None) and restart the webserver.

Otherwise the .htaccess settings are not evaluated.

  • Plz check this apache2.conf file screen shot: screencast.com/t/ceOUMcAEB2R At where should i make changes? My all files are into /var/www/html/. Can u plz suggest? – Ashesh Sep 25 '15 at 10:04
  • In the last part, <Directory /var/www/> as I guess the mentioned .htaccess file is located in /var/www/html/.htaccess. If you change it to AllowOverride All the settings of the .htaccess file will overwrite the server settings in the apache2.conf file. Hope this helps you ;) – Kozure Sep 25 '15 at 12:08
  • I think in addition you have to define the rewrite itself to make from http://yourmagentoshop.com/index.php -> http://yourmagentoshop.com. Here you can find an accepted solution stackoverflow.com/questions/10474740/… – Kozure Sep 25 '15 at 12:16
  • When i change to AllowOverride All, it stops working and giving me 500 internal server error. – Ashesh Sep 25 '15 at 12:41
  • For my every other pages on site, it gives me this error screencast.com/t/B6F2s7WdB Do you think, it is related to port 443 error? – Ashesh Sep 25 '15 at 12:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.