2

I tried to upload some image product in frontend. Before, button browse and upload were missing, then I have upgraded the latest flash mozila (firefox) and then browse and upload button were there but when i choose some images and click button upload, the image cannot upload well, so why that is happen? can you tell me the solution ? this issue just only in mozila firefox, in chrome worked well.

Capture:

enter image description here

  • - use firebug to check javascript conflict? - check the extension that you use for upload in frontend. – uscoding Sep 22 '15 at 4:57
  • i still cannot solve it anyway. whats this issue cause of SSL ? "the connection to this website is not fully secure because it contains unecrypted elements (such as images) or the encryption is not strong enough" thats text said on the top beside of url firefox mozila. in front of web http://, backend https://, in vendor page http://, but when going to product manager the url changed again to https:// – Yr Amelia Oct 22 '15 at 8:58
  • I've resolved this same issue locally for my current employer by implementing my own HTML5 based file uploader and scrapping Magento's flash-based nightmare. You may want to look into finding a modern replacement (or simply use a different browser). – Luke A. Leber Nov 18 '15 at 3:35
0

If you are using any CDN, then it may cause problems like this. When i had faced a problem in uploading images to mobile module in Magento Community Version, i just disabled the CDN urls from settings->configuration->design and tried uploading the pictures, and it works.

So try disabling the CDN and upload. hope this fix

  • i'm not using CDN, so what should I do to solve this issue ? – Yr Amelia Oct 23 '15 at 2:03
  • So when i read the above comment of yours regarding the SSL conflict, can you disable the SSL on the website and try. – Stanly Stephen Oct 23 '15 at 7:18
  • i've been trying, but what is this issue cause of SSL conflict? because only in firefox and operamini browser. in chrome worked well.. – Yr Amelia Oct 23 '15 at 8:19
  • finally it solved. i just go to system > configuration > general > web > tab secure > set Use Secure URLs in Frontend and Use Secure URLs in Admin to 'NO' you saved me! – Yr Amelia Oct 23 '15 at 9:15
  • Hi Stanly, if I have set it not secure, actually it works, but how to make it secure and passes certified from mozilla firefox and also can upload images ? let me know please.. – Yr Amelia Oct 26 '15 at 4:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.