3

I want to start with Magento 2. Unfortunately my VPS is running php 5.4 so i have to request an upgrade first, but when that is done, would i need composer always to install Magento 2 or is it just needed in beta?

Would i be better of waiting for the stable release to start my project?

5

Yes, you need Composer in installing Magento 2. Composer is a PHP package manager similar in concept to Maven for Java developers. It is a tool for dependent management in PHP which allows you to declare the dependent libraries your project needs and install them for you. Composer enables you to manage Magento 2, extensions, and their dependencies.

And you must need MySQL 5.6 or above in order to work with Magento 2.

If you are working on a project for a client, I would recommend you to go for Magento 1.9.2.1, which is the latest stable Community version available at the moment.

But you can play around with Magento 2 and get an idea on the existing release so far on GitHub.
Link: https://github.com/magento/magento2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.