0

exception 'PDOException' with message 'SQLSTATE[42000]: Syntax error or access violation: 1118 Row size too large. The maximum row size for the used table type, not counting BLOBs, is 65535. You have to change some columns to TEXT or BLOBs' in

I have multiple product attribute and I got below link https://www.sonassi.com/knowledge-base/magento-kb/mysql-limitations-on-the-flat-catalogue-in-magento/

because we want to use that attrbute in product listing also but its not helpful for me and I am using magento 1.7.0.2

1

This means you just have too many attributes that are added to the indexed table. Remove some of the attributes that are not shown on category pages from the indexed table. This is a limitation we cannot work around easily.

Have you applied the change that is suggested in the link you provided? If you do; Perhaps its better to disable the flat tables for products since there are too many attributes to display anyhow.

| improve this answer | |
  • How will i disable the flat tables for products? – user3322 Sep 23 '13 at 8:57
  • @user3322 System->Configuration->Catalog->Frontend – Marius Sep 23 '13 at 9:04

Not the answer you're looking for? Browse other questions tagged or ask your own question.