I'm trying to save the 3 API credentials that PayPal Website Payments Standard asks to be filled, but once I enter them and hit Save, the default values are back in place (strange).

The fields I'm referencing are:

  • API Username
  • API Password
  • API Signature

I have tried to tweak some of the rest of the options for that section, but the problem remains.

I also tried to save them from an uncached browser. I have the caches disabled. I tried to save them after logging out, and then logging in.

Additionally, I get this error when testing on the frontend (but this is, I guess, because the default details are in place and refusing to leave):

PayPal gateway has rejected request. Security header is not valid (#10002: Security error).

Do you have any idea where the culprit can be? Thanks,

  • in wich table you set the values in the db?
    – user33818
    Commented Dec 3, 2015 at 16:00
  • I have the same problem. What is the table containing these data? ... Can not find it in my installation, there is a certificate referred to but not the API Signature
    – Valentín
    Commented Jun 2, 2016 at 21:08

3 Answers 3


Your paypal account may have been restricted or you are connecting to the wrong endpoint possibly with the wrong credentials.

https://developer.paypal.com/docs/classic/api/errorcodes/ That is a good link but your error code is mentioned a number of times for many different reasons so your best solution is to contact PayPal. They should be able to tell you the exact reason.

  • Thanks for the ideas! Something was preventing to save the values, we went directly to the database to fix it, and it works, but we still do not know the WHY it happened... tested from different computers and browsers, so it has to be a Magento-specific issue.
    – Peanuts
    Commented Sep 15, 2015 at 16:49

This is what we did to fix it:

  1. We went to the database using PhpMyAdmin
  2. We entered the values directly on the database
  3. We then returned to the admin area, and saw those fields empty (no idea why)
  4. We finally entered again the values there, and it worked, but the default 6 dots to protect the passwords are still there (strange enough).

If someone has an explanation to add to it, it would be really really welcome!

  • Which were the fields you updated?
    – Ramses
    Commented Sep 6, 2017 at 0:49

We had the same problem and solved it by manually adding in database Paypal Security key, it worked then

Have a nice one,

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.