3

I have been trying everything to get order emails to work on a new Magento 1.9.2.1 installation. Despite everything being enabled under System > Configuration > Sales > Sales Emails and setting up a proper cron in cPanel, nothing ever happens. I have setup the same exact cron in cPanel for another installation and it works fine. Nothing I do seems to matter.

The cron_schedule table seems to periodically re-populate with new schedule_id's but they always show as "pending", and executed_at and finished_at are all null. The core_email_queue table has all the unsent emails there (with null in the "processed_at" fields).

Nothing appears in the exception or system logs.

  • 2
    Try use Aoe_Scheduler to check cron routines and run it manually. "From" emails are correctly configured in System > Settings > Sales > Sales Emails? – Denis Spalenza Sep 11 '15 at 16:15
  • It was my understanding that Aoe_Scheduler was not compatible with 1.9. Yes, emails are properly configured in Sales Emails settings. – mcpacific Sep 11 '15 at 16:38
  • does reset password email work? Are you sure that is not an smtp problem? – Antonino Bonumore Sep 11 '15 at 18:57
  • Aoe_Scheduler is compatible with 1.9.1.0 (I tested). I'm not sure about 1.9.2.1. Maybe a smtp problem (by @AntoninoBonumore)? – Denis Spalenza Sep 12 '15 at 3:17
1

Then you might be affected by a Magento bug. Open the file cron.php (back it up before editing) in the root directory of Magento and look for (around line 47):

$isShellDisabled = (stripos(PHP_OS, 'win') === false) ? $isShellDisabled : true;

After this line, add:

$isShellDisabled = true;

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.