3

Since today, my products have stopped displaying on the website! I don't remember making any changes to .xml, .phtml files. I have already gone through checking the stock, inventory, enabled, visibility, cache, index and so on. But they still won't show up.

I can still navigate to the products with the url-key. Also, noteworthy is that when I search for the products using search or advanced search, it comes up with results, but it just won't display it. Please see the screenshots below to understand the issue.

EDIT: Also, both search and advanced search seem to break the page i.e the footer doesn't show up too.

Case 1

However, when searching for a "hot huez" (name of a product), which matches the title of the product, it returns with what I believe to be the results without the actual product?

enter image description here

Case 2 (advanced search)

The advanced search even acknowledges that there is a product matching the criteria, but still doesn't display it. I'm at my wit's end, does anyone have any idea, what I might be missing?

enter image description here

Any help is greatly appreciated!

  • Try to reindex from the commandline and check for any errors – Sander Mangel Sep 9 '15 at 15:09
  • @SanderMangel How would I go on to do that? – Navik Goswami Sep 9 '15 at 15:09
  • 1
    Log in via SSH onto your server and from the directory Magento is in execute php shell/indexer.php reindexall – Sander Mangel Sep 9 '15 at 15:11
  • Otherwise reindex from backend but make sure they all finish and are updated (check date) and no errors are found in the Magento logging – Sander Mangel Sep 9 '15 at 15:13
  • can u try this .and lets see magento.stackexchange.com/a/78869/28660 – Sudhir Belagali Sep 9 '15 at 16:08
2

So after spending a few hours, I have finally found out the issue. I hope that this will help others facing the same issue and have no clue how to resolve it.

So what is the issue causing search to malfunction an break the HTML Page?

It's...

System > Configuration > Catalog > Use Flat Catalog Product

So, if you have "innocently" changed this setting to "Yes", this is going to break your search! So make sure this is set to "No" (like it is by default) and hopefully things should return to the normal course!

Phew!

  • I use flat catalog and have not had any problems like this. You should try the manual reindex via command line /usr/local/php55/bin/php-cli -f shell/indexer.php reindexall after saving this configuration. – Steven J Sep 25 '17 at 16:31
1

I've seen this many times.

If you're using Solr to drive your category and search and Solr goes down - or the index has become corrupt - Then all of your search results and category pages will return 0 results.

This is easily remedied in most cases by restarting Solr and reindexing the Catalog Search and related Flat catalog indexes.

  • I have no idea what Solr is and I have never used it. Sorry! – Navik Goswami Sep 9 '15 at 15:21
  • Has your systems integrator incorporated it? – philwinkle Sep 9 '15 at 15:21
  • No. I'm quite positive that we haven't incorporated Solr. – Navik Goswami Sep 9 '15 at 15:38
1

You should check the following items in the admin interface:

  1. In General -> Status must be set to Enabled, Visibility must be set to Catalog, Search
  2. In Inventory -> Quantity must be more than 0 and Stock Availability must be set to In Stock

Obviously, all the mandatory fields must be compiled and I suggest you specify some categories for the product.

  • As the question suggests, I have already checked these things beforehand. It doesn't make a difference. – Navik Goswami Sep 9 '15 at 16:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.