4

I migrate magento2 windows system to linux system with database. Home page of magento2 is working fine but other page is give error 404 not found. If I add index.php in frontend url then it's opening but without it not possible. And also magento admin is also not opening even after adding index.php in url.

  • You should set RewriteBase in your .htaccess and make sure that your Linux server have mod_rewrite activated and proper options are set in Magento backend. But generally, it's server-side issue. – talonkingvskg Sep 4 '15 at 9:27
  • i tried everything as you told but my problem is not solved yet – Yogesh Karodiya Sep 4 '15 at 9:48
6

Did you see AllowOverride All? This is a commonly overlooked step. Please see:

http://devdocs.magento.com/guides/v2.0/install-gde/prereq/apache.html#apache-help-rewrite

6

The problem was in my Apache server configuration the below procedure helped me solving this problem

For Ubuntu edit the file /etc/apache2/apache2.conf (here we have an example of /var/www)

<Directory /var/www/>
        Options Indexes FollowSymLinks
        AllowOverride None
        Require all granted
</Directory>

and change it to;

<Directory /var/www/>
        Options Indexes FollowSymLinks
        AllowOverride All
        Require all granted
</Directory>

then

sudo service apache2 restart

Source.

  • Thanks, this worked for me also, before trying this i tried a lot of different stuff. – Mukesh Jun 14 '16 at 19:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.