0

After I put my magento project on a linux server. I cleared all of cache. I removed all of the files from var/cache. I used this command

php -indexer --reindexall

everything was reindexed successfully. I even truncate the core_url_rewrite and did a new reindex all, BUT I still cannot access the subcategory urls. The category url I can access.

It might be worth to mention subcategories are actually a category + Amasty layered navigation filters in the URL

I selected NO for the Use Web Server Rewrites input, but still i get the infinite loop. So why do i get the infinite loop (for page loading) for subcategory urls ? Thx in advance !

8
  • in mage_core_config make sure you are using the correct domain name ( with www or none www) Commented Sep 4, 2015 at 11:40
  • i don't have any table named mage_core_config Commented Sep 4, 2015 at 12:43
  • Sorry, it should be core_config >> web/unsecure/base_url and web/secure/base_url Commented Sep 4, 2015 at 14:48
  • @AhmedElAwadi Yeah I am using the right urls. Commented Sep 7, 2015 at 8:50
  • I have similar redirect loop issue when I upgraded Magento from EE1.9 to EE1.14 and enabled Redis cache. The issue was due to wrong configuration of redis cache, redis needs to be put on different port. Hosting providers solved the issue for me. Commented Sep 7, 2015 at 11:06

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.