2

So not one person in all of this section can help troubleshoot session issues?

NOTE I've completely updated my question as this was never resolved:


EDIT: I just noticed that while I set 777 on var/session new files that are created are set to 600 (rw) Could this be the culprit?


If customer A adds product "pencil" to cart - customer A can checkout

If customer B adds product "pencil" to cart - customer B, C, D gets an empty cart

After customer A adds product to cart, no one can add to cart for that product - eventually you can but I haven't figured out why yet.

So I am leaning towards cookies or a session problem.

What I've already tried:

  • Set cookie life time to 24 hours (86400)
  • Set all indexes to Update on save
  • Re-index all indexes
  • Cleared all caches
  • Verified that var/sessions is 777
  • Disk is not full
  • No messages in the log files

Here is a portion of my Web configuration:

enter image description here

Do these settings look correct?

Are there additional steps that I can take to figure this out?

  • Have you tried to refresh the indexes and clear the caches? – Adi Sep 3 '15 at 14:10
  • Yes, all caches cleared, disabled, cleared var/sessions, var/locks, var/cache, re-indexed same thing. Not all products, only some. – SR_Magento Sep 3 '15 at 14:23
  • I don't think the permissions on the session files should be a problem, with 0600 set it means that the owner (in this case the web server account, who created them) can read and write them, and that's the only account that should ever need to. Even if you have a cron job to run housekeeping on var/session, running as a different user, it should be fine because it should just be deleting files and it's the directory permissions that matter then. – Doug McLean Feb 8 '16 at 9:29
  • It sounds like it could be an inventory issue - some sites have a system where if you add a product to cart it reserves that amount of stock for you, so if someone adds all available units then nobody else can buy it. After a certain amount of time a cart expires and that quantity is returned to stock. As I recall Magento doesn't offer this feature "out of the box" but I'm sure there are extensions that do. Any chance you've got one of them? – Doug McLean Feb 8 '16 at 9:33
  • Unfortunately I dont have such a system, my site downloads a csv file and imports the products but nothing that reserves any quantities. – SR_Magento Feb 8 '16 at 11:35
6
+100

Empty carts are usually one of two things in my experience:

  • Disk is FULL
  • There is an exception that is wrapped in a try/catch that traps the error but doesn't push to Mage::logException
  • There is a problem with sessions

In general, though, it's usually a full hard drive.

  • Merry Christmas here is 100 points for no reason – SR_Magento Feb 11 '16 at 13:25
5
+50

The products that don't work, are they using the same template as the ones that do? My first thought was a custom template missing the <?php echo $this->getBlockHtml('formkey');?> but then that should have been failing in 1.9.0.1 too.

Even so, if you're sure these products were OK before the upgrade then custom templates/blocks/models are a likely cause. Here are some things you can try:

  1. Check with the vendors of any third-party extensions you've got, that these extensions are compatible with 1.9.2.
  2. If you're using a custom theme, switch back to rwd/default (you can do this for a single product as a test) and see if the problem persists.
  3. Maybe an obvious one, but by the same token easy to take for granted: make sure logging is actually enabled. System > Configuration > Developer > Log Settings
  4. Check your web server log file (e.g. /var/log/apache2/error_log or /var/log/nginx/error.log)
  5. Temporarily remove / rename custom PHP code in app/code/local/Mage/* that you think might be involved, see if the app/code/core versions work any better.

Also, try and find a pattern to the problem. Is it only Simple products that are affected? Or is it Configurable products, or Bundles etc etc? Is it products with Special Prices? They're bound to have something in common.

Good luck! :)

  • +1 Lots of good info, 1. everything is compatible, 2. tough to switch on a production but will try 3. enabled, 4. nothing 5. I dont overrride core code in this manner but a good tip none the less. All products are the same Simple and I still dont understand why if I save that product it works again. – SR_Magento Nov 16 '15 at 15:31
  • Ah, I overlooked the part about products working after being saved. That sounds promising. I had a similar problem once where I'd created products via the API or via CSV import (I forget which) and one or two required attributes had not been set, though you couldn't tell that from the admin panel due to scoping issues (store view values vs. default values). Saving the product in the admin silently filled in the blanks. If it is that, you might be able to spot the omissions by exporting affected products as CSV. – Doug McLean Nov 16 '15 at 15:44
  • You might be onto something, I do use an import script, it could explain this issue. If I confirm this to be the reason I will award you the bounty. – SR_Magento Nov 16 '15 at 16:26
  • I found another product and unfortunately it didnt have any missing information that needed to be set :S – SR_Magento Nov 17 '15 at 14:15
2

We had exactly the same problem after updating to 1.9.2 from 1.7.0.2 and it was a session problem. Please check your cookie domain settings and use your domain name without "." It will be added by code.

  • My cookie domain is currently blank. Should I just put mydomain.com was your problem ALL products or just a random few that would pop up from time to time? – SR_Magento Nov 21 '15 at 10:29
1

So after months of trying to figure this out and 150 bounty points later, the solution is to set a minimum quantity in the cart:

  • System -> Configuration
  • Inventory -> Product Stock Options
  • Next to Minimum Qty Allowed in Shopping Cart click Add Minimum Qty
  • Set to ALL GROUPS quantity 1
  • Click Save

-

To recreate the issue:

  • Ensure there is no Minimum Qty Allowed in Shopping Cart set.
  • Add a product to cart
  • From the cart page, enter 0 as the quantity and press UPDATE SHOPPING CART and the cart will empty

This was some how happening immediately on add to cart but lack of interest from more experienced people in this community has me not caring either - just that I posted what fixed the issue.

0

To add additional solutions, only a select few of my bundled products would return an empty cart when the "add to cart" button was clicked.

Several of the child-products, the "not visible individually" products that were the specific size for the parent product were disabled, but for some reason they were still showing up as options in the drop down menu. Enabling them solved the issue for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.