0

Hi Struggling with this one, done some reading and tried checking for blank spaces at the end of files. I actually removed a few but this didn't fix the issue even after clearing the cache.

The system is not creating any session data. There is nothing in var/session

Here is the error that magento is reporting:

a:5:{i:0;s:126:"Cannot send headers; headers already sent in app/code/core/Mage/Admin/Model/Session.php, line 1";i:1;s:1409:"#0 lib/Zend/Controller/Response/Abstract.php(148): Zend_Controller_Response_Abstract->canSendHeaders(true)
#1 app/code/core/Mage/Core/Controller/Response/Http.php(106): Zend_Controller_Response_Abstract->setRedirect('http://planetto...', 302)
#2 app/code/core/Mage/Adminhtml/Controller/Action.php(348): Mage_Core_Controller_Response_Http->setRedirect('http://planetto...')
#3 app/code/core/Mage/Adminhtml/Controller/Action.php(182): Mage_Adminhtml_Controller_Action->_redirect(Object(Varien_Simplexml_Element))
#4 app/code/core/Mage/Core/Controller/Varien/Action.php(407): Mage_Adminhtml_Controller_Action->preDispatch()
#5 app/code/core/Mage/Core/Controller/Varien/Router/Standard.php(250): Mage_Core_Controller_Varien_Action->dispatch('index')
#6 app/code/core/Mage/Core/Controller/Varien/Front.php(172): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http))
#7 app/code/core/Mage/Core/Model/App.php(354): Mage_Core_Controller_Varien_Front->dispatch()
#8 app/Mage.php(684): Mage_Core_Model_App->run(Array)
#9 index.php(90): Mage::run('', 'store')
#10 {main}";s:3:"url";s:6:"/admin";s:11:"script_name";s:10:"/index.php";s:4:"skin";s:5:"admin";}

Look forward to getting any help.

  • 1
    check if the file app/code/core/Mage/Admin/Model/Session.php has an empty space or any character before the php open tag <?php – Marius Sep 2 '15 at 9:14
  • My bet is on file permissions... – Henry's Cat Sep 2 '15 at 9:15
  • In addition to @Marius his answer, check out this post about whitespaces causing the error: stackoverflow.com/a/8028987/387136 – Sander Mangel Sep 2 '15 at 9:19
  • I've checked for whitespaces and also ensured all file permissions are correct as per this page link Still no joy :S – user9654 Sep 2 '15 at 9:29
0

I had the same error:

a:5:{i:0;s:122:"Cannot send headers; headers already sent in /home/user/public_html/app/code/core/Mage/Admin/Model/Session.php, line 1";

Simple solution: in Session.php there was a space before <?php opening tag - just had to remove it.

-1

you can remove these three line from the following page.

Go to :

app\code\core\Mage\Core\Model\Session\Abstract\varien.php

// session cookie params
       $cookieParams = array(
           'lifetime' => $cookie->getLifetime(),
           'path'     => $cookie->getPath(),
           //'domain'   => $cookie->getConfigDomain(),
           //'secure'   => $cookie->isSecure(),
           //'httponly' => $cookie->getHttponly()
       );

and then try to login it worked for me.

  • Hmm that didn't do the trick either :S – user9654 Sep 2 '15 at 10:43
  • Improve PHP Memory Limit If you can access php.ini OR use .htaccess in the root OR edit index.php add below line right after ini_set(‘display_errors’, 1); ini_set('memory_limit', '256M'); try this – Donika Sep 2 '15 at 10:52
  • Thanks for your reply. Memory limit was set to 1024M, this had already crossed my mind. Also tried disabling extensions one by one. Still no joy. I also thought it might have been an issue with permissions on the var/session folder, so reset these and also still no joy :( – user9654 Sep 2 '15 at 11:01
  • try this : lampjs.wordpress.com/2015/01/02/… – Donika Sep 2 '15 at 11:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.