I am running in to weird issue.When i try to access the product url its going to 404 page.Its happening for for some products.

I tried to reindex,clean cache ,removed the url from url key in admin and saved again.

Still the same issue. any help would be greatly appreciated. This enterprise upgraded from EE 1.9.

  • I have faced this same issue before. And contacted Magento support team and they have upgraded for me. Aug 31 '15 at 12:57

If product URLs issue is still same after re-index the indices. Then please perform following step carefully.

If your store is live then please put site on maintenance mode using (maintenance.flag file) for some minutes while you perform following steps.

Step 1: Take a backup of table core_url_rewrite

Step 2: TRUNCATE (empty) TABLE core_url_rewrite

Step 3: Now re-index the indices .(Try re-index from SSH if possible.)


Please check the following steps:

1.Product is disabled or enabled (Enabled).

2.Product is assigned with some category or not(Assgined).

3.Check the core_url_rewrite Table.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.