0

I got strange problem. i have install magento 1.9 with sample data and using RWD / Base / our responsive theme without any custom.

I have set admin catalog to show 5,10,15,20. but on listing page alway show all product at one page:

http://dcctoyou.com/dev2/men/new-arrivals.html

How can I fix this issue ?

Note: I install Lazyload from mgt but I disabled it still show all products.

5
  • are you sure you don't have any other extension that hooks into the product collection and calls load or iterates through it before the limits are set?
    – Marius
    Commented Aug 21, 2015 at 8:18
  • I hav tried disabled all installed module. it still show all products. could you check admin for me ?
    – Ryo
    Commented Aug 21, 2015 at 8:24
  • @Ryo in what way did you disable modules? Commented Aug 21, 2015 at 9:48
  • I disabled through admin advance. I think I found problem. my template overwrite catalog page. but after I disable this module page navigator is just disappear.
    – Ryo
    Commented Aug 21, 2015 at 10:26
  • Disabling module output in admin panel only hides the blocks of the module but does not disable its functionality. Sounds like the problem comes from your custom theme and cannot be reproduced with the default rwd theme? In this case, please show relevant code, or the question is likely to be closed as not reproducible. Commented Aug 23, 2015 at 14:21

1 Answer 1

0

$collection = Mage::getModel('...') ->getCollection() ->setPageSize(5) ->setCurPage(1);

You may try this code

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.