1

I worked hard at my website (mag community), but now i can't login in the admin panel. I want to know if there is a simple solution to solve this problem. After i deleted all session from var/session, it works once, but now i have the same problem.

Please, any advices ? Thanks, silver

  • Can you describe your server setup? – kab8609 Aug 20 '15 at 20:18
  • Hello, thank you, here is the PhP setting: Register Globals: On, Safe Mode: Off, Magic Quotes: On, Upload Max Filesize: 15, POST Max Size: 15, Ioncube: Off, Zend: Off, Upload Max Filesize: 32 Mb. – Silver Aug 21 '15 at 3:41
  • Do you see just a blank page or can you see the login screen? If the latter, what happens when you type your username and password and click the login button? Does the page refresh or do you get a blank screen? What browser are you using? Have you tried using other browsers, clearing all browser cache and cookies? Please update your question with answers to those questions. It will make it much easier for the community to try and help you. – ForMat Aug 21 '15 at 6:12
  • cookies issue might be.. try increasing cookies time.. – Shyam Krishna Sreekumar Aug 21 '15 at 6:27
  • Thank you, i can type the user/password and nothing is happening. I use mozilla, but i tried also explorer and opera. The number of files from var/sessions, increase. Also, i clean up the cash, cookies from mozilla, but nothing. I repeat, the website works very well until now. – Silver Aug 21 '15 at 15:18
1

It could have something to do with the session storage. Try to save sessions to the database instead.

Open app/etc/local.xml and change

<session_save><![CDATA[files]]></session_save>

To

<session_save><![CDATA[db]]></session_save>
  • Thanks Jimmi, my http is "no", last time when i could login. regarding the data base, i'm afraid to not damage the database. If there is other solution, it will be perfect. i use mozilla. – Silver Aug 21 '15 at 15:24
  • could i damage something at my website, if i deleted the sesions fron var/sesions ? – Silver Aug 21 '15 at 15:31
  • Not really, at worst you will kill any logged in users in front end or back end and potentially delete the contents of shopping carts, but no permanent damage. More details in related question here. – Bryan 'BJ' Hoffpauir Jr. Aug 23 '15 at 11:53
1

Which browser used? If chrome it may happened. For this first take another browser and go to admin check the system->configuration->web->session & cookie management in that the http control set from Yes to No.

I hope it may help you.

0

I solved the problem by modify the core_config_data from database, i set: Cookies.path = '/'; Cookies.domain = 'example.com';

But now, i face with other issue, after i deleted the cache. My shipping settings have changed and i can't set only one country in the estimate shipping cost (on the front page). My default country is Romania, but the country field from checkout is empty and i can't estimate the shipping cost. I use magento 1.9.2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.