4

My client is on an old server running PHP 5.2.17, should I encourage him to upgrade to 5.3 or will it be ok?

6

The support for PHP 5.2 ended in August 2011, so I recommend to update the PHP installation. The configuration site on magentocommerce.com shows that PHP 5.3 is required.

Some weeks ago we had some issues with a PHP 5.4 installation, EE 1.12 and atomic repo (some segmentation faults) and we stepped back to 5.3.

Update: The error was

Fatal error: Cannot override final method Mage_Core_Model_Abstract::clearInstance() in various PHP-Files

with PHP 5.4.17

2

I suggest to try with PHP 5.4. If it is EE installation please talk to support first as 5.4 is not officially supported yet (not fully tested) but works correctly since 1.13/1.8 based on the feedback i got.

2
  • 1
    In my experience it seems to work - but there are reports / documented SimpleXML bugs regarding how Magento makes use of simplexml objects returning a custom class name/type.
    – philwinkle
    Sep 12 '13 at 19:07
  • We have also had issues with php 5.4 a while back, and downgraded to 5.3, thus suggest to go with 5.3
    – ProxiBlue
    Sep 13 '13 at 22:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.