0

I have a slider on this website: https://sportinngerritsen.nl/ and I'm trying to make it editable for the user through static blocks, but when I do this, it displays the slider like this: http://sportinn.portalserver.nl/.

I noticed that when I add the following HTML that is needed for the slider to the static block:

<div id="slider_wrapper">
<div id="slider_wrapper_inner">
    <div id="slider">

        <div id="feature_list">
            <ul id="tabs">
                <li>
                    <a href="javascript:;" class="current">
                        <h1>Bespanmachine nodig</h1>
                    </a>
                </li>
                <li>
                    <a href="javascript:;" class="">
                        <h1>De badminton collectie</h1>
                    </a>
                </li>
                <li>
                    <a href="javascript:;" class="">
                        <h1>Tennissnaren</h1>
                    </a>
                </li>
            </ul>
            <ul id="output">
                <li style="display: list-item;"><img src="http://sportinn.portalserver.nl/skin/frontend/default/sportinn/afb/catalog/slider/bespanmachines.jpg"></li>
                <li style="display: none;"><img src="http://sportinn.portalserver.nl/media/wysiwyg/badminton-home2.jpg"></li>
                <li style="display: none;"><img src="http://sportinn.portalserver.nl/media/wysiwyg/tennissnaren-home5.jpg"></li>
            </ul>
        </div>

    </div>
</div>

It automatically changes it to this after I updated the HTML:

<div id="slider_wrapper">
     <div id="slider_wrapper_inner">
        <div id="slider">
            <div id="feature_list">
               <ul id="tabs">
                  <li>
                      <h1>Bespanmachine nodig</h1>
                  </li>
                  <li>
                      <h1>De badminton collectie</h1>
                  </li>
                  <li>
                      <h1>Tennissnaren</h1>
                  </li>
              </ul>
              <ul id="output">
                  <li style="display: list-item;"><img alt="" src="http://sportinn.portalserver.nl/skin/frontend/default/sportinn/afb/catalog/slider/bespanmachines.jpg" /></li>
                  <li style="display: none;"><img alt="" src="http://sportinn.portalserver.nl/media/wysiwyg/badminton-home2.jpg" /></li>
                  <li style="display: none;"><img alt="" src="http://sportinn.portalserver.nl/media/wysiwyg/tennissnaren-home5.jpg" /></li>
              </ul>
            </div>
        </div>
    </div>
</div>

Hence, it removes the <a href="javascript:;". Does anyone know why this works when I paste it in page.phtml but doesn't when I use it in a static block? I recently updated from 1.6.2 to 1.9.2.1 and it did work before the update.

0

I guess the editor doesn't consider the html as valid and removes the a tag.
you can try to paste this after you disable the editor. or you can just use href="#".

  • I see, thank you! I didn't know I could disable the editor, but this fixed it. Thanks again! – user3478148 Aug 19 '15 at 18:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.